EPDM Coatings
rvupgradestore.com Composet Products Custom Yacht Interiors

Author Topic: Invisibrake Problem  (Read 604 times)

kcgaz

  • Posts: 2
Invisibrake Problem
« on: January 08, 2017, 03:32:53 PM »
I am new to this forum, so I want to say thank you in advance for any and all assistance.  I purchased a 2011 Chevy HHR with an Invisibrake system and can't seem to get it to work. I purchased the LED warning light that mounts in the motorhome, all other components appear to be in the tow vehicle. I have connected the HHR to our 2003 Holiday Rambler and nothing happens with the Invisibrake unit.  Should the unit come on, make any noise etc?  I have checked the fuse and all seems to be OK. Any help would be greatly appreciated.

Arch Hoagland

  • ---
  • Posts: 1495
  • Clovis CA
Re: Invisibrake Problem
« Reply #1 on: January 08, 2017, 04:04:40 PM »
http://www.roadmasterinc.com/products/braking/invisibrake/ 

That site has links to the manuals.

Do you know if it ever worked for the previous owner?

How are you connecting the motorhome brake lights to the HHR?
2004 Monaco La Palma 36 DBD
W22, 8.1 gas,  Allison 1000 Transmission
7.1 MPG over 80,000 miles

2000 Lexus RX300, 4020lb
U.S. Gear Braking System

kcgaz

  • Posts: 2
Re: Invisibrake Problem
« Reply #2 on: January 08, 2017, 04:46:46 PM »
Thanks very much for the link to the manuals, I actually have them and they have not been much help unfortunately. I am using a Blue Ox BX88206 Coiled Cable.  I even bought this new because I thought my old cable might have a short, but nothing.

Arch Hoagland

  • ---
  • Posts: 1495
  • Clovis CA
Re: Invisibrake Problem
« Reply #3 on: January 08, 2017, 05:48:13 PM »
Thanks very much for the link to the manuals, I actually have them and they have not been much help unfortunately. I am using a Blue Ox BX88206 Coiled Cable.  I even bought this new because I thought my old cable might have a short, but nothing.

So do you know if they ever worked? 
2004 Monaco La Palma 36 DBD
W22, 8.1 gas,  Allison 1000 Transmission
7.1 MPG over 80,000 miles

2000 Lexus RX300, 4020lb
U.S. Gear Braking System

Greg Barker

  • ---
  • Posts: 61
Re: Invisibrake Problem
« Reply #4 on: January 09, 2017, 07:52:57 AM »
Are you turning on the headlights in the MH? I'm not a 100% sure if they need to be on just for the rear lights or the braking system to work. My system will make a buzzing noise when activated.
Greg & Kristina
2016 Winnebago Sunstar 31 KE
2015 Toyota Tacoma 4wd
Rocklin California

 

Hosted by Over The Network