EPDM Coatings
rvupgradestore.com Composet Products Custom Yacht Interiors

Author Topic: Guardian Model 004700 4000W generator cuts off in Arizona heat  (Read 274 times)

tomhilton

  • Posts: 2
I have a Coachmen 2006 Ramp and Camp that has a 4000W Guardian Gas Generator.  When the temp in Arizona reaches 100F this generator will cut itself off after about 10 minutes of running.
The Generator service guys said it is the Oil Temp sensor.  During the summer, most days and even some night in Arizona is 100F plus.  Any ideas on how to get this thing to run in this heat?

BoonDocker Bob

  • Guest
Re: Guardian Model 004700 4000W generator cuts off in Arizona heat
« Reply #1 on: May 08, 2017, 06:22:58 AM »
Have you ever actually checked the oil temp ( with an infrared temp reader ) . If it is getting above the "safety" zone temp for the engine , well , the only thing you can try is a higher viscosity oil  , say like 50 weight ( not multi weight - straight weight and NOT cheap oil either - they break down WAY too fast . HIGH engine temperatures is what kills oil FAST )
Also , make sure the genny is getting plenty of air circulation all around it  ----if possible
« Last Edit: May 08, 2017, 06:25:05 AM by BoonDocker Bob »

cgmartin

  • ---
  • Posts: 559
Re: Guardian Model 004700 4000W generator cuts off in Arizona heat
« Reply #2 on: August 13, 2017, 06:44:22 AM »
tomhilton, did you ever figure out what the problem was with your generator?

tomhilton

  • Posts: 2
Re: Guardian Model 004700 4000W generator cuts off in Arizona heat
« Reply #3 on: August 15, 2017, 06:29:12 AM »
I tried 50 weight oil which let it run a little longer.  But the real fix was to sell the RV.

 

Hosted by Over The Network