EPDM Coatings
rvupgradestore.com Composet Products PO Box Zone
Over The Network Custom Yacht Interiors

Author Topic: Water Pump not kicking on (2006 Beaver Monterey IV)  (Read 186 times)

06beavermontereyIV

  • ---
  • Posts: 22
Water Pump not kicking on (2006 Beaver Monterey IV)
« on: July 04, 2017, 11:18:31 AM »
I have a 2006 Beaver Monterey IV (Diesel Pusher) approx 20K miles. We've owned it for about a year. I've noticed just recently that when I'm either hooked up to shore power or without shore power with the inverter on or generator that when you hit the Water Pump switch throughout the coach that it's not turning on. The light on the switch comes on but no water. I've water in my holding tank. I've checked the fuses and switches in the bathroom area (not for sure which one actually controls the water pump). Any suggestions where else I might look to see if their are any fuses blown? The only other place I know that there are electrical connections are outside on the drivers side front. Thanks. Happy 4th of July

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60421
  • RVer Emeritus
Re: Water Pump not kicking on (2006 Beaver Monterey IV)
« Reply #1 on: July 05, 2017, 10:58:10 AM »
If you have multiple pump switches there will be a pump controller that actually turns it on/off. It switches the ground (aka "low") side of the pump circuit. The pump should have +12v on its hot side at all times. So, check the wires at the pump to verify the +12v. If no 12v, look for the fuse that supplies the circuit. If 12v is present, connect a temporary ground to see if it the pump runs. If yes, find the controller and replace. If not, replace the pump.
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

06beavermontereyIV

  • ---
  • Posts: 22
Re: Water Pump not kicking on (2006 Beaver Monterey IV)
« Reply #2 on: July 05, 2017, 07:30:23 PM »
Thanks Gary, I will follow your instructions. Roy

06beavermontereyIV

  • ---
  • Posts: 22
Re: Water Pump not kicking on (2006 Beaver Monterey IV)
« Reply #3 on: July 06, 2017, 09:20:43 AM »
Thanks for your help. I located the pump in a underneath compartment close to the refrigerator water filter in a side wall compartment. Gary I checked the positive terminal which was hot and after checking the negative terminal I found a bad connection. Cleaned the negative terminal up and it came right on! Sometimes we get lucky! Thanks again for your help. Have a great day. Roy
« Last Edit: July 06, 2017, 06:02:56 PM by 06beavermontereyIV »

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60421
  • RVer Emeritus
Re: Water Pump not kicking on (2006 Beaver Monterey IV)
« Reply #4 on: July 07, 2017, 09:56:03 AM »
Good to hear it was a simple problem!
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

 

Hosted by Over The Network