EPDM Coatings
rvupgradestore.com Composet Products PO Box Zone
Over The Network Custom Yacht Interiors

Author Topic: Generator runs 30 minutes, shuts off  (Read 573 times)

mweber (KC9NPT)

  • ---
  • Posts: 132
Generator runs 30 minutes, shuts off
« on: July 19, 2017, 12:26:25 PM »
My Onan NHE 6500 just started with this problem. Starts fine and will run for 30 minutes with a/c on. Shuts off and will restart if I wait about 3 minutes and runs for another 30 or so minutes. If I try to start it before the 3 minutes, starter cranks but engine won't catch. Gas tank is over 3/4, oil is full, new air cleaner, so I'm at a loss.
Merrill
KC9NPT

2000 Itasca Suncruiser 35U
2002 Wrangler
2005 Liberty
Chicago 'burbs, IL

Rene T

  • ---
  • Posts: 9838
  • Great being on the right side of the grass
Re: Generator runs 30 minutes, shuts off
« Reply #1 on: July 19, 2017, 01:37:48 PM »
My Onan NHE 6500 just started with this problem. Starts fine and will run for 30 minutes with a/c on. Shuts off and will restart if I wait about 3 minutes and runs for another 30 or so minutes. If I try to start it before the 3 minutes, starter cranks but engine won't catch. Gas tank is over 3/4, oil is full, new air cleaner, so I'm at a loss.

I wonder if the low oil level sensor may be acting up. When the block heats up, things inside the sensor may expand breaking the circuit causing the shut down. When it has time to cool, the circuit closes allowing it to start. I'm sure there must be a way to bypass the sensor to troubleshoot.
Rene & Lucille & co-pilot Buddy
AKA  Pep N Mem
2011 Chevy Duramax 2500 HD 4X4
2011 Montana High Country 343RL
From the Granite State of NH
& Florida Snowbird in Lakeland FL

supermanotorious

  • ---
  • Posts: 527
    • Phoenix Winch LLC
Re: Generator runs 30 minutes, shuts off
« Reply #2 on: July 19, 2017, 01:45:16 PM »
usually you can simply disconnect the low oil sensor to bypass it
Home is Phoenix, AZ
2008 Skyline Freestyle M-240 Way-Lite
2003 Harley Davidson Dyna FXDX
2003 Chevrolet Avalanche 2500 8.1L 496ci 4x4
1994 Four Winns Freedom
various quads, off-road gokarts, mini bikes
Phoenix Winch wakeboard winches

Rene T

  • ---
  • Posts: 9838
  • Great being on the right side of the grass
Re: Generator runs 30 minutes, shuts off
« Reply #3 on: July 19, 2017, 02:24:03 PM »
usually you can simply disconnect the low oil sensor to bypass it

If there were two wires going to the sensor, wouldn't you need to connect them together after disconnecting from the sensor?
Rene & Lucille & co-pilot Buddy
AKA  Pep N Mem
2011 Chevy Duramax 2500 HD 4X4
2011 Montana High Country 343RL
From the Granite State of NH
& Florida Snowbird in Lakeland FL

mweber (KC9NPT)

  • ---
  • Posts: 132
Re: Generator runs 30 minutes, shuts off
« Reply #4 on: July 19, 2017, 03:18:19 PM »
I wonder if the low oil level sensor may be acting up. When the block heats up, things inside the sensor may expand breaking the circuit causing the shut down. When it has time to cool, the circuit closes allowing it to start. I'm sure there must be a way to bypass the sensor to troubleshoot.

Iwouldn't think 2 -3 minutes would let it cool enough to run for another half hour, but I'll look into that.
Merrill
KC9NPT

2000 Itasca Suncruiser 35U
2002 Wrangler
2005 Liberty
Chicago 'burbs, IL

supermanotorious

  • ---
  • Posts: 527
    • Phoenix Winch LLC
Re: Generator runs 30 minutes, shuts off
« Reply #5 on: July 19, 2017, 03:36:34 PM »
If there were two wires going to the sensor, wouldn't you need to connect them together after disconnecting from the sensor?

maybe, even probably, but- you'd know immediately because you wouldn't get spark with one, admittedly I've only done this on engines with single wire to the sensor
Home is Phoenix, AZ
2008 Skyline Freestyle M-240 Way-Lite
2003 Harley Davidson Dyna FXDX
2003 Chevrolet Avalanche 2500 8.1L 496ci 4x4
1994 Four Winns Freedom
various quads, off-road gokarts, mini bikes
Phoenix Winch wakeboard winches

Rene T

  • ---
  • Posts: 9838
  • Great being on the right side of the grass
Re: Generator runs 30 minutes, shuts off
« Reply #6 on: July 19, 2017, 04:00:57 PM »
maybe, even probably, but- you'd know immediately because you wouldn't get spark with one, admittedly I've only done this on engines with single wire to the sensor

With one wire setup, would you need to connect it top a good ground
Rene & Lucille & co-pilot Buddy
AKA  Pep N Mem
2011 Chevy Duramax 2500 HD 4X4
2011 Montana High Country 343RL
From the Granite State of NH
& Florida Snowbird in Lakeland FL

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60387
  • RVer Emeritus
Re: Generator runs 30 minutes, shuts off
« Reply #7 on: July 20, 2017, 10:45:26 AM »
Service manual available at http://www.twinslan.net/~n0nas/manuals/onan/940-0502%20Onan%20NHE-NHEL%20(spec%20A-C)%20RV%20Genset%20Service%20Manual%20(07-1987).pdf

Vapor lock of some sort seems like a possibility.  2-3 minutes is enough for a fuel line to cool a bit and condense back to liquid fuel.

Question: Is it exactly 30 minutes, and is it the exact same interval each time?  Some of the later spec level Onans have timed checks for things like temperature sensors, so that they can detect failed sensors. For example, if a sensor report is missing or unchanged for xx minutes, it might shut down.
« Last Edit: July 20, 2017, 10:55:59 AM by Gary RV_Wizard »
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

elbeau54

  • ---
  • Posts: 5
  • A man"s got to know his limitations.
Re: Generator runs 30 minutes, shuts off
« Reply #8 on: August 05, 2017, 03:11:04 PM »
Gary ,i am fixing to change my temp sensor on a 7500 gas unit, any tips ? I know i have to pull it  out
Elwood Anderson  Timmonsville S C

mweber (KC9NPT)

  • ---
  • Posts: 132
Re: Generator runs 30 minutes, shuts off
« Reply #9 on: August 05, 2017, 03:25:01 PM »
Sorry, forgot to post what I did.  Genny had synthetic oil in it. I drained it and put in straight SAE 30 and problem so far has been solved.
Merrill
KC9NPT

2000 Itasca Suncruiser 35U
2002 Wrangler
2005 Liberty
Chicago 'burbs, IL

elbeau54

  • ---
  • Posts: 5
  • A man"s got to know his limitations.
Re: Generator runs 30 minutes, shuts off
« Reply #10 on: August 05, 2017, 03:55:49 PM »
Changed mine to 30 w ,still cuts off,new sensor for temp on way
Elwood Anderson  Timmonsville S C

catblaster

  • ---
  • Posts: 2132
Re: Generator runs 30 minutes, shuts off
« Reply #11 on: August 05, 2017, 03:58:11 PM »
Sorry, forgot to post what I did.  Genny had synthetic oil in it. I drained it and put in straight SAE 30 and problem so far has been solved.

I would suspect that the oil was foaming but synthetics are not supposed to do that.......would the resistance be different and throw off the sensor??
Will and Jane
95 Winnebago Luxor

cgmartin

  • ---
  • Posts: 535
Re: Generator runs 30 minutes, shuts off
« Reply #12 on: August 13, 2017, 09:42:33 PM »
elbeau54, are those sensors hard to replace? My Onan 4000 generator is doing the same thing. I have the K model. Would you please let me know if that resolves the problem for you? I am beginning to think that this is a heat related problem.

Re: Generator runs 30 minutes, shuts off
« Reply #13 on: August 22, 2017, 08:10:25 PM »
I also have an Onan 4k generator in a 2004 Winnebago Minnie which shuts off after 40-60 minutes. Fuel tank is full. When I took off the generator cover there was some foam insulation pieces in front of the fan. After looking at some Youtube videos, I think this was a solid piece between the compartment wall and the fan with about 3-6 inches of air space in between - maybe for sound reduction. I wonder if some pieces may have broken up and were sucked in by the cooling fan which has reduced the air flow and is causing it to overheat and shut off. So, my questions: Has anyone else had this overheating problem caused by blocked air flow? If so, were you able to clear the air passages and how did you do it? I'm guessing you have to remove the generator to do it. Thanks for any help..

cgmartin

  • ---
  • Posts: 535
Re: Generator runs 30 minutes, shuts off
« Reply #14 on: September 10, 2017, 06:34:06 PM »
Photos of new location of my fuel filter and pump in order to alleviate possible issues with vapor lock.

Mosagra

  • ---
  • Posts: 168
  • 1999 itasca Suncruiser, gas, Onan 5000
Re: Generator runs 30 minutes, shuts off
« Reply #15 on: September 16, 2017, 02:52:26 PM »
I can tell you that when I had a similar problem it was the fuel pump.  Fuel pump would stop working above a certain temp.

B737doc

  • ---
  • Posts: 49
  • 1992 Challenger
Re: Generator runs 30 minutes, shuts off
« Reply #16 on: October 03, 2017, 05:35:23 PM »
Check YouTube.....one guy had the exact same problem.  Sucked out one pint of oil, problem solved. 
1976 BMW R90/6 "Airhead"
2005 Triumph Bonneville "America"
1992 Challenger Motorcoach

 

Hosted by Over The Network