EPDM Coatings
rvupgradestore.com Composet Products PO Box Zone
Over The Network Custom Yacht Interiors

Author Topic: stumped on a water heater  (Read 246 times)

andrew3744

  • ---
  • Posts: 20
stumped on a water heater
« on: July 29, 2017, 03:10:37 PM »
when my motorhome is plugged in, my Atwood water heater will work ignite just fine. when I'm running on coach battery power it will sometimes not ignite. The battery is also good I just replaced it.

8Muddypaws

  • ---
  • Posts: 2235
Re: stumped on a water heater
« Reply #1 on: July 29, 2017, 04:53:58 PM »
Long shot:

Have you checked the voltage at the waterheater?  How about the current?

Corroded connections anywhere?
Retired computer professional
Musician, songwriter and music director
2006 Bounder 34H, 2008 CR-V Toad

OLDRACER

  • ---
  • Posts: 957
Re: stumped on a water heater
« Reply #2 on: July 30, 2017, 07:17:02 AM »
Replacing the battery does not guarantee that voltage is up to par, at least for very long, and there have been cases where new batteries are not performing. Sounds to me like the battery is either not getting a full charge, or that the terminal connections or ground connections are not good. I agree with 8Muddypaws, check everywhere!

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60355
  • RVer Emeritus
Re: stumped on a water heater
« Reply #3 on: July 30, 2017, 07:22:36 AM »
Agree with the others - it appears the voltage level is the difference. On shore power, your coach 12v system is operating at around 13.6v, whereas on battery it is at best 12.6v and goes down from there as the battery discharges over time. A poor quality wire connection might work adequately at 13.6 but not at 12.0v-12.6v.

You might start with the wire from the heater circuit board to the igniter, cleaning the connection to the board (a pencil eraser works!). And check the voltage where the 12v comes to the heater board as well, comparing that to the voltage at the battery. See if there is excessive loss between the two.
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

andrew3744

  • ---
  • Posts: 20
Re: stumped on a water heater
« Reply #4 on: July 30, 2017, 01:07:02 PM »
Thanks for all suggestions! I cleaned all the connections and it seems to be working consistently now!

 

Hosted by Over The Network