RVing message boards > Tech Talk

Atwood OD-50 brand new self installed wont fire

(1/2) > >>

llegovski:
Hi everyone, I would really appreciate some input from you knowledgable people.

Ive got a tiny house (ok not quite an RV) that Ive been building and I put an Atwood OD-50 on demand LP water heater off of Amazon in it.  It came with three wires sticking out, a red (hot), blue (lockout lamp, optional) and green (ground).  It wants 12v DC power but my tiny house is wired AC and plugged into a 15amp extension chord.  So I went down to the local RV repair spot and they suggested getting a little AC adapter.  Input 1.8 amps, output 12v 5amps.  They told me to snip the DC plug off and get a switch, then wire the positives from the heater and the DC converter to the switch, and wire the ground from the heater and the DC converter to a ground wire that I ran to my chassis.  I also ran two ground wires from my AC box, one to the chassis and one to a grounding rod.

Now when I fired up the hot water heater and flipped that switch, it started humming and trying to ignite before I even turned the water on.  I turned the water on and it fired up.  I turned the switch off to see what would happen and it turned off.  Ever since then no matter what I do it wont fire.  That humming sounded weird to me, and I dont hear that anymore either- though I suppose it couldve been the vent fan.  There is still a very faint clicking when I run the water through it but it does not sound like an igniter to me.

Any ideas?  Have I messed something up here?

Thanks so much guys!

Ernie n Tara:
Something doesn't sound right. A converter that draws 1.8A ac should have an output of 15A dc or more. Possibilities :

 * The converter may need a filter (battery or similar) to, provide clean curent
*  Current may be inadequate to heat the water
*  May have turned on before you had water in the heater and burned out the heating element

I'd try to operate it off a 12V auto battery to check that it isn't damaged. If it works then the converter is bad or inadequate for the task. If not look to the heater.  My bet is that the heater requires more current than is available.

Ernie

Gary RV_Wizard:
Yeah, try a well-charged 12v battery to see if works with clean 12v power of sufficient voltage.  If it does, maybe that 12v power adapter is the problem. There are lots of alterantives there.

However, it worked, sort-of, the first time. Your report suggests that either the heater was miswired or that adapter doesn't really put out 12v.  Possible damage to the heater control board?   Does its rating sticker actually state 12.0 or something close to that? The heater should be happy with anything in the 12.0-14.0 range.

llegovski:
Thanks to both of you for the advice.  Before I go out and buy a battery I did check the output from the converter with my voltmeter.  It read a steady 12.4v...  Is that enough to say its a clean output or are there other factors involved?

If the converter is ok then its also possible that I had a shitty connection to my switch, Im gonna rule that out today.

Gary RV_Wizard:
Don't buy a battery just for that - hook it to a car battery for an hour or so. It's just a test.

12.4v and steady seems adequate, but does it hold up under load?  There is also a phenomena called AC ripple that can only be seen on an oscilloscope.

Navigation

[0] Message Index

[#] Next page

Go to full version