Sponsored by Winnebago Industries

Author Topic: 2005 Itasca Cambria won't start  (Read 127 times)

dlphil

  • Posts: 1
2005 Itasca Cambria won't start
« on: January 26, 2018, 09:54:24 PM »
Having unusual problem with 2005 Itaska Cambria.  If left for several days (plugged in to shorepower), will not start although chassis battery is charged. Makes funny little noise and the instrument needles jump around for a few seconds.. From then on it starts fine.Bososter doesn't seem to help.   Any Clues??

John Canfield

  • Forum Staff
  • ---
  • *
  • Posts: 12088
    • Jane and John's Internet Home
Re: 2005 Itasca Cambria won't start
« Reply #1 on: January 27, 2018, 11:00:46 AM »
Offhand it sounds like your chassis batteries are the culprit. Pull them and have them load tested at an auto parts store. If they are more than five years old, time to replace them anyway.
--John
2005 Horizon 40AD, 2006 Jeep Rubicon Unlimited
Our Horizon projects
Our weather

spencerpj

  • ---
  • Posts: 137
Re: 2005 Itasca Cambria won't start
« Reply #2 on: January 27, 2018, 12:18:19 PM »
Sounds to me like a ground problem.  exam all your connections, and connections to chassis

John Canfield

  • Forum Staff
  • ---
  • *
  • Posts: 12088
    • Jane and John's Internet Home
Re: 2005 Itasca Cambria won't start
« Reply #3 on: January 28, 2018, 07:20:24 AM »
^^ Another excellent tidbit of advice ^^
--John
2005 Horizon 40AD, 2006 Jeep Rubicon Unlimited
Our Horizon projects
Our weather

 

Hosted by Over The Network