rvupgradestore.com Composet Products Fridge Defend
RV Life Magazine RV Park Reviews RV Trip Wizard

Author Topic: 95 raven p30 dash cluster problem at a loss  (Read 408 times)

95raven

  • Posts: 2
95 raven p30 dash cluster problem at a loss
« on: February 25, 2018, 02:13:03 PM »
Hey guys ....first post here so hello an thanks for having me .....im travis an i live in atlanta ....anyhoooo i have a 95 raven on a p30 chevy chassis all has been well until yesterday started rv up checked some stuff turned off loaded family up fired truck back up an didnt have any gauges working ...no service light ext .....whats wierd is a few things ok turn key on an truck will run an drive radio cameras heat an air all work ...jus no truck info  mph ,temp fuel an chaarging ....headlight buzzer stays on with lights so i have checked fuses an they all are good pulled cluster an all looks good also jus fyi high beam indicater is working cluster lights up jus no truck info also wont shift into od ....i assume cause its not sending mph to trans ....i went an got a new electrical switch for colum an still no change also no power to the instrament fuse took a power prob an probed around under hood an all seems to be passing power any help would be greatly appreciated .....

sc4668

  • ---
  • Posts: 119
  • 2007 Denali fifth wheel
Re: 95 raven p30 dash cluster problem at a loss
« Reply #1 on: February 25, 2018, 02:48:04 PM »
Could be ignition switch, I have seen this before on other vehicles.

Isaac-1

  • ---
  • Posts: 1267
Re: 95 raven p30 dash cluster problem at a loss
« Reply #2 on: February 25, 2018, 11:48:09 PM »
I too would look at the ignition switch it should be at the base of the steering column (the key actuates it with push rods).  The ignition switches on the P30's were prone to overheat if the RV manufacturer added too many accessories to the circuit.  Workhorse eventually added a relay bypass retrofit to solve the issue of overheating ignition switches.
2002 Safari Trek 2830

95raven

  • Posts: 2
Re: 95 raven p30 dash cluster problem at a loss
« Reply #3 on: February 27, 2018, 06:43:50 AM »
Like i said got new switch ....still have the issue ...strange thing is the fuse for gauges is dead ...the 5 amp

sc4668

  • ---
  • Posts: 119
  • 2007 Denali fifth wheel
Re: 95 raven p30 dash cluster problem at a loss
« Reply #4 on: February 27, 2018, 02:34:52 PM »
If you changed the ignition switch at the base of steering column did you adjust it the mount is slotted where the screws attach to column. Did you inspect connector to switch I have seen the wires melted and the plastic where the pins go thru melted. The reason you do not have 12v to 5 amp fuse is because it is not getting there from the ignition switch.