Sponsored by Winnebago Industries

Author Topic: City water problem  (Read 284 times)

vrjohnson2

  • Posts: 2
City water problem
« on: March 05, 2018, 03:05:30 PM »
Hello, I have a water fill problem. I have a 2003 Itasca 38G Suncruiser. I cannot get the water to work when I connect a hose and turn it to city water. I have to put it on water fill and let my tank fill up and then use it from the tank. Any idea what could be wrong? Thanks, Rick J.

John Hilley

  • ---
  • Posts: 1722
Re: City water problem
« Reply #1 on: March 05, 2018, 03:31:55 PM »
Sounds like the Water Fill Valve is broken and not able to move to the City Water position. Fairly common problem.
2003 Winnebago Adventurer 38G
1999 Jeep Cherokee Sport
1999 Winnebago Brave 35C
  Handicap Lift & Hospital Bed

vrjohnson2

  • Posts: 2
Re: City water problem
« Reply #2 on: March 05, 2018, 03:39:08 PM »
Thanks for the reply, but you can hear the water change when you turn the valve plus if I leave the valve in the tank fill position it comes out the over flow when the tank gets full, so I switch it back to city fill. Any other ideas? How would you fix the valve? Thanks.

JakeR

  • ---
  • Posts: 115
Re: City water problem
« Reply #3 on: March 05, 2018, 04:14:35 PM »
Is the issue with both cold and hot or just hot?
Jake
Northern CO
2017 Winnebago Navion 24J
2010 Toyota Corolla (manual) toad

John Canfield

  • Forum Staff
  • ---
  • *
  • Posts: 12362
    • Jane and John's Internet Home
Re: City water problem
« Reply #4 on: March 05, 2018, 05:01:20 PM »
....How would you fix the valve?....
You replace the two way valve. My money is on a bad valve like John suggested.
--John
2005 Horizon 40AD, 2006 Jeep Rubicon Unlimited
Our Horizon projects
Our weather

 

Hosted by Over The Network