rvupgradestore.com Composet Products Fridge Defend
RV Life Magazine RV Park Reviews RV Trip Wizard

Author Topic: Furnace wasn't working until I spun the heat anticipator?  (Read 209 times)

MilkMan

  • ---
  • Posts: 7
Furnace wasn't working until I spun the heat anticipator?
« on: August 16, 2019, 01:54:55 AM »
With lows of 43 degrees it was unfortunate to find our furnace not kicking on. No clicking or fan kicking on. Full propane, full battery and other propane appliances working.

In the middle of the night I popped open the analog thermostat and spun the heat anticipator forward and back. To my surprise the furnace turned on. I moved it back to where it was at about 1.2.

I have no clue why that helped. Is my thermostat faulty?

2016 Cherokee Wolf Pup 16BHS Travel Trailer

John From Detroit

  • ---
  • Posts: 22815
  • ^My New Home^
    • Diabetics Forum
Re: Furnace wasn't working until I spun the heat anticipator?
« Reply #1 on: August 16, 2019, 06:37:12 AM »
Basically that device is like a volume control. the contact (one of 2) was dirty and you cleaned it by moving it. So yes it WAS defective and YOU fixed it.
Nothing adds excitement like something that is none of your business
My Home is where I park it.

Rene T

  • Forum Staff
  • ---
  • *
  • Posts: 14120
  • Every day is payday and every payday I have off
Re: Furnace wasn't working until I spun the heat anticipator?
« Reply #2 on: August 16, 2019, 09:04:28 AM »
Agree. I would spray some contact cleaner in there.
Rene, Lucille & co-pilot Buddy
AKA  Pep N Mem
2011 Chevy Duramax 2500 HD 4X4
2011 Montana High Country 343RL
From the Granite State of NH
& Florida Snowbird in Lakeland FL