EPDM Coatings
rvupgradestore.com Composet Products
RV Life Magazine RV Park Reviews RV Trip Wizard

Author Topic: thermostat, furnace issue. 2004 windsport rv  (Read 1965 times)

windsportowner

  • Posts: 2
thermostat, furnace issue. 2004 windsport rv
« on: November 03, 2005, 05:14:53 PM »
o.k. so I had my rv in for service on the front a/c a few months ago.  While camping this weekend we tried to turn on the furnace (which we had not previous problems) and nothing.  When we hit the mode switch to go to it, there was not even a furnace option.  Just a/c, fan, and off.  Anyone have any idea what the service department has done now? :-[

Tom

  • Administrator
  • ---
  • *
  • Posts: 46031
  • Celebrating 25 years of The RV Forum online.
    • RV Forum web site
Re: thermostat, furnace issue. 2004 windsport rv
« Reply #1 on: November 03, 2005, 06:34:39 PM »
The confort control on our coach can be reset if it exhibits strange symptoms. The reset procedure should be in your owners manual. Also on our coach the propane has to be on and the batteries can't be discharged or it won't go into 'furnace' mode. Hoefully others will have additional suggestions.
Tom.  Need help? Click the Help button in the toolbar above.

windsportowner

  • Posts: 2
Re: thermostat, furnace issue. 2004 windsport rv
« Reply #2 on: November 04, 2005, 07:08:14 AM »
Thanks Tom.  I have heard that it may be the dip switch in the front a/c that needs to be reset.  I will let you know when (and if) I find the problem.  If not I will have to take it back to Mcgeorge Rolling Hills RV for service for the 11th time since I purchased it a year and 1/2 from them new. 

rick

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 63650
  • RVer Emeritus
Re: thermostat, furnace issue. 2004 windsport rv
« Reply #3 on: November 04, 2005, 07:54:16 AM »
Make sure your thermosat is set for the right "zone" or a/c unit.  The furnace control will be on only one of the two zones shown on the t-stat, so if Heat or Furnace does not show as a mode option on one zone, try the other.  Or maybe the shop forgot to reconnect the hea wiring to the t-stat and it's not on either zone an more?
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL