EPDM Coatings
rvupgradestore.com Composet Products
RV Life Magazine RV Park Reviews RV Trip Wizard

Author Topic: Crazy Guages 95 Pace Arrow  (Read 1028 times)

95pace

  • ---
  • Posts: 67
Crazy Guages 95 Pace Arrow
« on: August 06, 2011, 10:06:52 PM »
We were on our way to Outer Banks this past week when all my guages went crazy.Our unit is a 95 pace on p30 chassis 454 ,temp guage went out completely,oil pressure just kept bouncing back and forth,alt guage went to full then back the other way.The coach was running fine but I stopped, raised the dog box ,everything seemed fine.When I started back out on road everything went back to normal  for a few miles then it did it again.We spent the rest of the trip down with this problem and  the way back.When I got home I replaced temp sending unit  but it still is not working.Others seemed ok for now anyone have any ideas.
Thanks,
Doug

BrotherBill

  • ---
  • Posts: 156
Re: Crazy Guages 95 Pace Arrow
« Reply #1 on: August 06, 2011, 10:25:39 PM »
Might have lost the ground for the panel.
Bill & Joan
Bandit & Cookie
Kansas City, MO
95 Dutch Star

Jeff

  • Forum Staff
  • ---
  • *
  • Posts: 9009
Re: Crazy Guages 95 Pace Arrow
« Reply #2 on: August 06, 2011, 10:27:38 PM »
IIRC our 1983 P-30 Pace Arrow had a ground strap on the instrument cluster that corroded enough to cause the indications you are describing. I finally ran a ground wire from the instrument panel to a steel brace supporting the steering column that fixed the problem.

PS: Oops, Brother Bill beat me to it. ;D

PCarillon

  • ---
  • Posts: 308
Re: Crazy Guages 95 Pace Arrow
« Reply #3 on: August 06, 2011, 10:38:56 PM »
Definatly sounds like a ground issue
Paul
2016 Outlaw 38RE