EPDM Coatings
rvupgradestore.com Composet Products Custom Yacht Interiors

Author Topic: Converter problem  (Read 5993 times)

donkita

  • ---
  • Posts: 13
Converter problem
« on: September 11, 2006, 09:25:15 AM »
I just purchased a '93 Jayco Class B. It's in great shape and everything seems to work. One problem that is a mystery to me is this: when I am plugged into AC power, everything works (refrig, micro, a/c, lights), but the VCR and TV will not work. They will both turn on, and the VCR strats to play, thens shuts down. The TV shows some static and squiggly lines, then a black screen. Seems like the converter is not producing enough power, but this happens even if I turn everything else off and only run the TV/VCR through the converter. The TV/VCR work fine with the vehicle running. Anyone have any experience or advice to share?
Thanks,
Donkita

Ned

  • Former Staff
  • ---
  • Posts: 25574
  • Ned and Lorna are former full time RVers
    • Have you seen Rolling Stock?
Re: Converter problem
« Reply #1 on: September 11, 2006, 09:39:56 AM »
Those are 12V devices?  I would suspect the converter isn't putting out enough power and/or the batteries are low or bad.  Since they work when the engine is running and are powered from the alternator, that would further indicate a battery/converter problem.
-- Ned -- Fulltimer 1997-2013
1997 Holiday Rambler Endeavor LE
2007 GMC Canyon

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60996
  • RVer Emeritus
Re: Converter problem
« Reply #2 on: September 11, 2006, 10:24:07 AM »
Odd that the tv and vcr are 12V powered.  12V tvs used to be fairly common, but I cannot ever recall seeing a 12V vcr.

But if you are sure these  devices are 12V powered, you likely have hit the nail on the head. Can you locate the converter and identify the make & model?  It may be combined with the 120VAC breaker panel or may be a separate unit. Much easier to replace if it is separate.
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

donkita

  • ---
  • Posts: 13
Re: Converter problem
« Reply #3 on: September 11, 2006, 10:36:25 AM »
Thanks for the replies. Both the TV and VCR are plugged into cigar lighter type plugs, so I assume 12V. What is strange to me is that I can run the A/C, micro, refrig, and lights all at the same time, but if I turn all of this off and just try the TV and VCR, they try to work but don't. How could the converter have enough power for all of that, but not just for the TV and VCR? Maybe I don't fully understand how the converter works. Batteries were mentioned, but the only battery I'm aware of is the one under the hood, which is brand new. Anything further would be appreciated.
Thanks,
Donkita

Ned

  • Former Staff
  • ---
  • Posts: 25574
  • Ned and Lorna are former full time RVers
    • Have you seen Rolling Stock?
Re: Converter problem
« Reply #4 on: September 11, 2006, 10:49:09 AM »
The A/C is not DC powered, and neither is the microwave.  The refrigerator uses 12V only for the contorls and that is very little current draw.  Lights may be working, but are probably not full brightness.  Do they light up more when the engine is running?  Have you checked the DC voltage with a voltmeter?  Check the voltage when on battery only, converter running, and with the engine running.  Those readings can probably tell us what the problem is.

I'm not familiar with the Jayco you have but most RVs have one battery for the engine and one for the house systems.  It's possible you have only one battery however, that powers both sides.  If so and the engine starts without a problem, then it's unlikely the battery is the problem.  That puts the focus on the converter.  The above mentioned voltage readings will narrow it down.
-- Ned -- Fulltimer 1997-2013
1997 Holiday Rambler Endeavor LE
2007 GMC Canyon

donkita

  • ---
  • Posts: 13
Re: Converter problem
« Reply #5 on: September 11, 2006, 11:24:12 AM »
The converter is a separate unit mounted under on of the rear bench seats, with wiring running to a power block on the outer wall; easily accessed. I have noticed a battery sized box located under the vehicle close to where the converter would be mounted. I assume, then, that this is the extra battery for the appliances, etc. If so, would it be likely that the replacement of this battery would solve the problem? I will need to raise the vehicle to make a positive ID, because, with the running boards, it is too low to get under the vehicle, and there doesn't appear to be accessfrom inside (unless underneath the converter). I will check this out and the other testing procedures suggested, and get back with you if I need further help. By the way, this is a small camper with no bathroom, plumbing, etc; only a small refrig and the other appliances previously mentioned. So i just assumed there was only the one battery. Thanks for straightening me out.
Donkita

Ned

  • Former Staff
  • ---
  • Posts: 25574
  • Ned and Lorna are former full time RVers
    • Have you seen Rolling Stock?
Re: Converter problem
« Reply #6 on: September 11, 2006, 11:38:47 AM »
Do check that box for a battery and get it load tested.  It would be a poor design if it was only accessible from underneath the vehicle.  Look around for an access panel inside.  I would still suspect the converter, but the voltage readings will help us figure that out.
-- Ned -- Fulltimer 1997-2013
1997 Holiday Rambler Endeavor LE
2007 GMC Canyon

John From Detroit

  • ---
  • Posts: 19792
  • ^My New Home^
    • Diabetics Forum
Re: Converter problem
« Reply #7 on: September 11, 2006, 04:31:41 PM »
Odd that the tv and vcr are 12V powered.  12V tvs used to be fairly common, but I cannot ever recall seeing a 12V vcr.

But if you are sure these  devices are 12V powered, you likely have hit the nail on the head. Can you locate the converter and identify the make & model?  It may be combined with the 120VAC breaker panel or may be a separate unit. Much easier to replace if it is separate.

I think it is Daewood makes a 12vdc VCR,  If you go to most any auto store (IE Pep Boys, Murrays Auto, Sears auto though I don't know if they still have them since K-mart moved in) you will find "Video in a bag" sets, consist of a small (5-10 inch) televison and a VCR DVD or both, all 12 vdc
Nothing adds excitement like something that is none of your business
My Home is where I park it.

King

  • ---
  • Posts: 355
Re: Converter problem
« Reply #8 on: September 11, 2006, 07:04:26 PM »
Sounds like a Magnatek 6332 converter.  I have the same system in my Class B Pleasureway.  You can't run the 12V tv or 12v VCR or an unfiltered fluorescent light on the converter.  The 12 V output is an unfiltered rectified sine wave.  They have separate connections to run off the house battery.  If the units work when under way, the chassis alternator is providing voltage to the house battery.  I tried running the TV with the battery disconnected, and get exactly what was described.  Find the house battery and try to get it charged up.  It probably needs to be replaced.
Art

King

  • ---
  • Posts: 355
Re: Converter problem
« Reply #9 on: September 11, 2006, 07:20:42 PM »
My TV and VCR are Audiovox 12V units made for RV and Marine in that era.  Actually the video tape unit is a VCP or VTP (video cassette player, video tape player) because it has no recording capability.  Initially I had a problem with the tv antenna amplifier, and was looking to buy a new TV.  Many of the 14 in LCD TVs made today operate of an in line power brick, and actually require 12V.   Funny, the CRT TV set takes 4A at 12 V, the same as an LCD unit.
Art

donkita

  • ---
  • Posts: 13
Re: Converter problem
« Reply #10 on: September 12, 2006, 08:08:52 AM »
Thanks to everyone for all of the information. I apologize for being so uninformed. King, you are right, it is a Magnatek converter. Last night I put the van up on ramps to get to the battery box (there was no access from inside). The end panel of the box was secured by one bolt at the bottom, with the top part in a slot. After wrestling with the bolt (and using a variety of tools and penetrants), I finally got it open and pulled out what was probably the first battery ever put in, a Thermoil deep cycle oil battery (never heard of an oil battery before). Went to the auto store and bought a new deep cyle battery, installed it, and everything works fine. Thanks again.

John From Detroit

  • ---
  • Posts: 19792
  • ^My New Home^
    • Diabetics Forum
Re: Converter problem
« Reply #11 on: September 12, 2006, 08:17:18 AM »
You might want to look at the Progressive Dynamics Intella-charger with Charge Wizard option.  Much better than that magnatech
Nothing adds excitement like something that is none of your business
My Home is where I park it.

Ned

  • Former Staff
  • ---
  • Posts: 25574
  • Ned and Lorna are former full time RVers
    • Have you seen Rolling Stock?
Re: Converter problem
« Reply #12 on: September 12, 2006, 08:25:41 AM »
Donkita, glad to hear all is well again.  That battery is an antique :)
-- Ned -- Fulltimer 1997-2013
1997 Holiday Rambler Endeavor LE
2007 GMC Canyon

Gary RV_Wizard

  • Forum Staff
  • ---
  • *
  • Posts: 60996
  • RVer Emeritus
Re: Converter problem
« Reply #13 on: September 12, 2006, 06:27:36 PM »
For a while Magnetek made a plug-in replacement upgrade for the 6300 series converters - you might check to see if one is availble for yours. Basically you took the guts out of the 63xx box and replaced it with new guts labeled 73xx. The 73xx series was much better, though no where near as good as the Progressive Dynamics or Iota units now available.

The  Thermoil was/is a pretty good battery - it has a layer of oil above the water in the cells to reduce the loss of battery fluid due to evaporation when charging.
Gary
--------------
Gary Brinck
Summers: Black Mountain, NC
Home: Ocala National Forest, FL

 

Hosted by Over The Network