EPDM Coatings
rvupgradestore.com Composet Products Custom Yacht Interiors

Author Topic: Concertone Enterainment System/Please Help  (Read 558 times)

TXPower

  • Posts: 2
Concertone Enterainment System/Please Help
« on: June 19, 2016, 06:33:52 PM »
We just bought a 2006 Forest River Wild Cat 5th Wheel.  The unit is in really good condition.  As we learn to use all the functions we find a problem with the Concertone Entertainment Center. 

I used the search function and found lots on t Concertone, mostly bad, but I didn't find a post that addressed our issues. 

The FM/Surround works perfect.  The DVD function worked perfect.  The camper only had one monitor, left in it.  It looks like the one that went in the master or bunk room.  When we checked the TV function at first we got nothing.  We tinkered with it for a while and finally figured out how to run it through an automatic channel set-up. 

We live about 35 miles from Dallas, so the signal should be strong here.  It only found two channels during automatic channel set-up .  It played the audio from one of the two channels it found through the surround, the other was hit or miss, mostly static.  The system did not play any of the video on the monitor, it just stayed blue.  The monitor hangs on the wall next to two plugs a yellow, marked video and a red, marked power. 

I had the antenna fully raised.  In the master bedroom, the same plugs are present.  Next to them is a small switch that I gather is a signal booster for the antenna, it was on as evidenced by the green light. 

To the right of the Concertone control unit is an outlet with two coaxial plugs for the antenna.  I brought a flat screen TV out to the camper and ran a coaxial cable from the top coax plug to the back of the TV first, nothing.  Next I ran the coaxial cable from the bottom plug on the outlet to the TV, this time  I was able to run the auto setup and it found about 20 digital TV stations, a bunch of channels we wouldn't watch like shopping channels.  None of the regular network channels were found.

I tried using an rca cable from the video outlet on the wall into my flat screen.  Got nothing.  Only TV I could get ran completely independent of the Concertone system.

So what do ya'll think, is there a problem with the TV portion of the Concertone system only?  Or did I do something wrong or am I missing something?  Please help.

Thanks,

TXPower

bross

  • ---
  • Posts: 319
Re: Concertone Enterainment System/Please Help
« Reply #1 on: June 19, 2016, 07:55:25 PM »
I don't know anything about your unit or Concertone but in my first fifth wheel I had an outlet like the one you described. One coaxial plug on the outlet went to the antenna and the second one went to the other TV. To get antenna signal to the front TV I had to put a jumper between the two plugs on the outlet.

Something easy to try.
« Last Edit: June 19, 2016, 08:16:20 PM by bross »
Bill & Doris
Winnebago Adventurer 38Q

TXPower

  • Posts: 2
Re: Concertone Enterainment System/Please Help
« Reply #2 on: June 20, 2016, 01:52:09 PM »
Ok bross, I'll try that, thank you.  No one else with experience with this type system?  Or suggestions how to upgrade or move forward?

Thanks,

TXPower

 

Hosted by Over The Network