EPDM Coatings
rvupgradestore.com Composet Products PO Box Zone
Over The Network Custom Yacht Interiors

Author Topic: HT755CR ALLISON  (Read 726 times)

bigred41

  • ---
  • Posts: 10
HT755CR ALLISON
« on: July 31, 2016, 09:51:29 AM »
Guys I have a Prevost CC conversion with an 8V-92 Detroit and an HT755CR tranny.Iam having a problem with the bus not wanting to go into gear after it has been parked for a couple of weeks.The first time I had this happen ,we had it towed to an Allison repair shop and of course once it got there ,it went into gear every time they tried it.They piddled with it for a month withe the outcome being they could find nothing wrong ,so after changing the fluid and filters I was presented with a bill for 1400 dollars but nothing was resolved.When it refuses to go in gear the light comes on on the shift pad and after running the the engine it will eventually go in gear or I can turn the ignition switch off and back on it will go in gear .It stores no codes after these episodes and all other aspects of the tranny seems to work as it should.I have learned to somewhat live with this but it kind of gets old when you are in the middle of no where having the pucker factor go to a ten every time I start this thing wondering if this will be the time that it won't go in gear at all.I would take it to another repair facility but I have not had very good luck with Transmission shops.Seems they can do well on them if it is dead in the water ,but diagnosing a intermittent problem can break the bank .I went down this road with Clark Power on my previous coach and wound up spending 4500 hundred dollars for what wound up being a 30 dollar gasket.

utahclaimjumper

  • ---
  • Posts: 2932
Re: HT755CR ALLISON
« Reply #1 on: July 31, 2016, 09:16:00 PM »
 Hey Red,, Run this problem past the guys at Bus Conversion Magazine Bulletin board.. they probably have more hands on experience than most.>>>Dan
38' American Tradition 38TT/330 turbo Cummins
Jeep liberty 4 down
72 VW Baja 4 down
Cedar City, Utah
USAF vet. 59-63
The difference between intelligence & stupidity is: intelligence has it's limits
      Albert Einstein.
President Western GM Coach chapter FMCA

Brass Rat

  • Posts: 2
Re: HT755CR ALLISON
« Reply #2 on: October 21, 2016, 03:22:49 PM »
I may be a tad slow on replying to this post, but I am fairly familiar with that Allison transmission situation.  My Prevost has the same engine and tranny.  My suggestion: crawl under the transmission on the left side and look/feel around for a bundle of wires coming out of a connector on the transmission.  Likely it will be a greasy mess, so use brake cleaner spray and lots of rags.  Wear goggles and set up a fan to blow the fumes away from you.  That stuff is strong!

The problem you are looking for is frayed wires, and/or a loose connection.  Isolate the bare wires, tape them up and while you are there neatly encase the bundle in some wire loom split tubing then secure with cable ties.  Also ... disconnect the wire bundle at the transmission housing and clean the contacts with CRC electronic cleaner.

I don't know why mechanics sometimes will ignore the obvious, but trust me, I've been through the same situation and I ended up fixing it myself.  Now the transmission goes into gear as soon as I select a position.  No lag or waiting, or turning the key off then back on.

 

Hosted by Over The Network