The RV Forum Community

RVing message boards => Bus Conversions, Buses => Topic started by: jdw73187 on March 31, 2017, 07:21:50 PM

Title: 1988 Allison Transmission Electrical ??
Post by: jdw73187 on March 31, 2017, 07:21:50 PM
Hello,  New member here looking for answers.  I have a 1988 Chevrolet School Bus with Detroit engine and Allison transmission.  It has not been converted to a camper.  I've just searched all I can search online and found this site.

The bus has been parked for approximately 3 months with being started and moved around on a farm.  Tuesday we drove it to a local shop, approximately 8 miles away.  There was no work done on it at the shop.  Driving home we stopped at a railroad crossing, and after checking that it was clear, when the accelerator was pressed there was no movement.  The engine revs up, but doesn't do anything with the transmission.

It was running perfect before the problem.  The only thing that had happened was coming to a stop for the railroad tracks.  There is an obvious electrical problem with the bus, but that isn't new.  The 4 way flashers light up when the horn is pressed.  The headlights activate the 4 way flashers.  I don't think the high beams can be cut on and off.

We've checked all the fuses under the dash.  And we've checked that transmission to see if the gear selector is actually moving the selector on the transmission.  The reverse lights do not come on when it the selector is placed in Reverse.

Any suggestions from anyone?  We are stuck.

Thanks
Title: Re: 1988 Allison Transmission Electrical ??
Post by: Utclmjmpr on April 05, 2017, 06:53:24 AM
 Trans fluid??leaks??>>>Dan