The RV Forum Community

RVing message boards => Winnebago-specific issues => Topic started by: Kjack on September 09, 2017, 10:46:46 PM

Title: Winnebago View Electrical Problem
Post by: Kjack on September 09, 2017, 10:46:46 PM
I have a 2015 Winneebago View 24G.  I have lost all power to the coach except when he engine is running.  That is the only time the Coach Battery Disconnect Switch will work. 
I have new batteries and they do test good, but no power is getting to the coach and the disconnect switch does not light up (not functional)  HELP!!!

edit by staff - changed message icon to topic solved
Title: Re: Winnebago View Electrical Problem
Post by: afchap on September 10, 2017, 07:54:00 AM
Worked before new batteries installed.  Does not work after. The disconnect switch and must be connected to 12 volt power to operate. I suspect something was not properly connected with the new battery installation. The house side is getting power from the engine alternator when the engine is running, but not getting power from the house batteries at all. If there is nothing obviously not connected in the house battery compartment, it may take a technician and/or comparing pictures of the battery connections on another coach of your model to determine what is not properly connected. I always take pictures and sometimes also draw a diagram of how the batteries are connected before I take anything loose.
Title: Re: Winnebago View Electrical Problem
Post by: Kjack on September 10, 2017, 11:10:23 AM
afchap

Thanks for the reply.  I did take pictures before and after the batteries were changed; they are the same.
My problems started last month with a factory electrical recall and service.  Nav system would require an engine shut down and restart to start working properly and the coach disconnect switch was  very dim.  Now no light on the switch at all.  All these problems were before the batteries were replaced.
Title: Re: Winnebago View Electrical Problem
Post by: John Canfield on September 10, 2017, 06:21:12 PM
What have you done in the way of troubleshooting?
Title: Re: Winnebago View Electrical Problem
Post by: Kjack on September 11, 2017, 09:33:44 PM
 afchap,
You were 100% correct.  I took the pictures of the battery installation, but the I did not see.  Once the ground to the master disconnect was established, everything seems fine.  My humble pie has been consumed.
Title: Re: Winnebago View Electrical Problem
Post by: afchap on September 11, 2017, 10:00:57 PM
Fantastic!  It is easy to miss something in the jumble of wires.  Thanks for the report back.