The RV Forum Community

RVing message boards => Motorhomes => Topic started by: Kevin Means on November 10, 2017, 03:28:15 PM

Title: Rain and Electrical Issues
Post by: Kevin Means on November 10, 2017, 03:28:15 PM
An interesting thing happened to us the other day, and I thought I'd mention it here in case others ever encounter it. Three days ago, we were climbing a long 6% grade on I-8, in a driving rainstorm with a howling crosswind. We were near the top of the Laguna Pass, when all the sudden my dash lights started lighting up like a Christmas tree - starting with the dreaded red Stop-Engine light. Wonderful

One by one, all the lights started lighting up, and my Silverleaf display indicated that I could only get 73% power (load) from the engine. I could definitely feel the power loss. I pulled to the side of the freeway in a wide spot and shifted into neutral. After sitting there for about 10 seconds, trying to figure out what was wrong, the lights started to go out. The Silverleaf was indicating that all parameters were in the green.

Within about 30 seconds, all the lights were out, except the Check-Engine light. Since the Silverleaf was indicating no alerts/exceedances, I pulled back onto the freeway, but I still only had 73% power. After about 10 minutes we crested the grade and I pulled over again to troubleshoot. This time, I shut the engine down and waited about 30 seconds. When I restarted it, everything was fine - like it never happened, and no Check-Engine light.

I suspected that water had gotten into a circuit somewhere and faked out the ECU, but the reduction in engine power was real. The next day I called Freightliner and they agreed with my assessment. They said the engine power reduction was most likely the ECU's response to a perceived emission control problem. They recommended that I unplug the 16 pin plug that's near the transmission, and seal it with dialectric grease. They said they have received reports of similar problems in the past, and most were traced to that plug.

One other observation... Having that Silverleaf display, with all its diagnostic information available at a glance, was VERY helpful. Every parameter is displayed numerically, but they're also color-coded, so you don't have to interpet numbers (Although you can if you want to.) If everything's green, you're good to go. If you've been thinking of getting one, I'd highly recommend it.

Kev
Title: Re: Rain and Electrical Issues
Post by: Gary RV_Wizard on November 11, 2017, 09:55:50 AM
I had some similarly bizarre electrical problems with a previous coach, a gas chassis rig. Turned out the wiring harness to the right headlight had a broken plug that was shorting out, sometimes enough to briefly trip the auto-reset breaker and the rest of the time a high resistance short that was probably overloading the alternator (wipers & defrosters on as well as daytime headlights). I couldn't find it at the time but it wiggled itself to a non-problem after a awhile.   I found it several days later when working on something else.