The RV Forum Community

RVing message boards => Bus Conversions, Buses => Topic started by: CaptainTwinTails on November 03, 2013, 06:35:46 AM

Title: Bus wont start....
Post by: CaptainTwinTails on November 03, 2013, 06:35:46 AM
good news I did finally get the registration taken care of and been driving around for the last 2 months or so. A purple School bus sure turns a lot of heads. well last night she wonted start...very sad. its done this a few times and a shift to drive then back to neutral or a little bang to the shifter seemed to do the trick but not this time. so...what do I need to do to fix it? I've read something about a neutral safety switch/and that it can be a bypassed.
1990 C60 8.2 carpenter body
Title: Re: Bus wont start....
Post by: Gary RV_Wizard on November 03, 2013, 08:12:31 AM
"Won't start" covers a lot of territory - can you be more specific? I gather the engine isn't even cranking, but please tell us exactly what happens (or doesn't happen) when you attempt to start??    Dash lights up? Transmission panel lights up, position of key and shifter lever or button? Condition of batteries? Etc.
Title: Re: Bus wont start....
Post by: Rene T on November 03, 2013, 08:29:47 AM
I had the same issue with a Dodge Caravan we just got rid of. Once in a while, it wouldn't do anything while in Park. All I would need to do is shift it to neutral and it would turn over and start OK. There's a switch in steering column that apparently was not activated in Park but would be in neutral. This would happen to me maybe once a month.  Did you try that?
Title: Re: Bus wont start....
Post by: CaptainTwinTails on November 03, 2013, 01:01:43 PM
turned out its the starter....lucky it happen in front of my house but it now will have to sit there for at lest a week.
Title: Re: Bus wont start....
Post by: kjansen on November 03, 2013, 01:19:20 PM
I have an International bus conversion that has an Allison tranny.  The shifter must be in neutral but every once in a while it still wouldn't start.
Turns out the bendix was dirty and needed cleaning, but in the mean time, smacking it with a hammer seemed to knock it loose and it started.  Still have the bus but use a 5er now instead.  Should sell the bus.
Title: Re: Bus wont start....
Post by: CaptainTwinTails on November 08, 2013, 10:57:33 AM
my starter came and I got it on...but now the battery's are dead??? took the one terminal off and its been off scents Sunday, why would the battery's go dead from that?

ok... there not dead the bus is just not getting any power?
Title: Re: Bus wont start....
Post by: utahclaimjumper on November 10, 2013, 03:16:58 PM
 It appears you may have "thrown a starter at the problem" before determining  the "real" problem. Always do the cheapest stuff first! (check battery cables, grounds, connections,.>>>Dan