rvupgradestore.com Composet Products Fridge Defend
RV Life Magazine RV Park Reviews RV Trip Wizard

Author Topic: Onan Generator won't start ....... no spark  (Read 41508 times)

Lake Pirate

  • ---
  • Posts: 7
Onan Generator won't start ....... no spark
« on: June 26, 2011, 05:26:04 PM »
I have a Generator,  Onan Emrald III plus.........gasser........ran it low on oil (Shame on me!) ..........the unit shut down..........low oil safety shut off..........refilled oil, and installed the cap.........won't start..........pulled plug and I have no spark.........what to do, what to do????
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

seilerbird

  • Guest
Re: Onan Generator won't start ....... no spark
« Reply #1 on: June 26, 2011, 05:38:57 PM »
Lots of generator problems this week.

What happens when you hit the start switch, absolutely nothing, does it make a clicking sound, does it make a clunking sound, does it turn over and not fire or does it fire up and die?

Water Dog

  • ---
  • Posts: 2490
Re: Onan Generator won't start ....... no spark
« Reply #2 on: June 26, 2011, 05:58:09 PM »
What is the model # of your Emerald?
Dennis

"Heart is where the home is"
---------------------------------
Dennis & Vici Bernhard
2000 Bounder
1999 Jeep Wrangler
Home: Sumner, TX

Lake Pirate

  • ---
  • Posts: 7
Re: Onan Generator won't start ....... no spark
« Reply #3 on: June 26, 2011, 07:28:29 PM »
It will turn over as it should..........just won't start.......acts like it wants to run..............got it to start one time by just holding the starter till she fired.........thinking of checking the low oil pressure sensor.........maybe bypass it and try to start ??????  Don't have the model # till tommarrow
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

Water Dog

  • ---
  • Posts: 2490
Re: Onan Generator won't start ....... no spark
« Reply #4 on: June 26, 2011, 08:44:26 PM »
Depending on the model, the oil pressure is either a normally open or normally closed switch which closes and opens to ground. Pull the wire off the oil pressure/level switch, then see if it will start, if not, try grounding it and see if it will start. If it starts in either one of those conditions, then the oil pressure switch is bad (or there is low oil level or low oil pressure). The oil pressure switch is next to the oil filter behind the sheet metal.
Dennis

"Heart is where the home is"
---------------------------------
Dennis & Vici Bernhard
2000 Bounder
1999 Jeep Wrangler
Home: Sumner, TX

Lake Pirate

  • ---
  • Posts: 7
Re: Onan Generator won't start ....... no spark
« Reply #5 on: June 26, 2011, 09:14:27 PM »
will give that a try tommarrow..........thanks
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

Lou Schneider

  • Global Moderator
  • ---
  • *
  • Posts: 9715
Re: Onan Generator won't start ....... no spark
« Reply #6 on: June 26, 2011, 11:59:00 PM »
The other thing that will cause an Onan to shut down as soon as you release the Start switch is no AC output from the generator.

Probably not applicable in this case but something to keep in mind for the future.

Lake Pirate

  • ---
  • Posts: 7
Re: Onan Generator won't start ....... no spark
« Reply #7 on: June 27, 2011, 12:28:32 PM »
Well, went out to bypass the low oil preeure sensor.........that did not start it...........checked oil again........was OK..........pulled plug, had spark in the gap..........touched the plug to ground and it acted like it wanted to run.............after that;  it acted like it wanted to fire while starting, when i let off the starter it would quit...........got it to run by holding down on the start button more than i should have to..........when it started; it was very rough running, but then smoothed out..........thought i would let it run some.........after about 5-10 minutes i thought i would put a load on it.........emmidiatly died on me........WTH :(
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

seilerbird

  • Guest
Re: Onan Generator won't start ....... no spark
« Reply #8 on: June 27, 2011, 01:14:22 PM »
Do you have less than a 1/4 of a tank full of gas? Most won't run without it being over 1/4th of the way full.

Lake Pirate

  • ---
  • Posts: 7
Re: Onan Generator won't start ....... no spark
« Reply #9 on: June 27, 2011, 01:34:04 PM »
good on fuel............been there, done that
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

Lou Schneider

  • Global Moderator
  • ---
  • *
  • Posts: 9715
Re: Onan Generator won't start ....... no spark
« Reply #10 on: June 27, 2011, 02:02:02 PM »
Check the generator voltage when you put the load on - if it drops to zero before the generator cuts out (should drift to zero as the generator slows) it's a sign of a bad control board or dirty slip rings preventing the generator from putting out full power.  Then when the voltage drops the no voltage shutdown kicks in.

Water Dog

  • ---
  • Posts: 2490
Re: Onan Generator won't start ....... no spark
« Reply #11 on: June 27, 2011, 05:21:46 PM »
Lake Pirate, it could be one of several things. Onans have to sense, oil pressure, field flash, and AC voltage in order to stay running. Problems could be from the circuit board, dirty slip rings, voltage regulator, or oil pressure switch. There is a great troubleshooting guide here. They also sell parts pretty reasonably priced (compared to others) and have a good tech support staff. If you suspect dirty slip rings, they sell a great tool for cleaning them for like $20. Just go item by item down the trouble shooting guide.

...when it started; it was very rough running, but then smoothed out..........thought i would let it run some.........after about 5-10 minutes i thought i would put a load on it.........emmidiatly died on me........WTH :(

Sorry, just read your post again....missed the part about you saying that you actually had it running. If it will actually run after you release the start switch, I would suspect a fuel issue....gummed up carb, dirty filter, bad fuel pump, or stuck choke
« Last Edit: June 27, 2011, 06:40:48 PM by Water Dog »
Dennis

"Heart is where the home is"
---------------------------------
Dennis & Vici Bernhard
2000 Bounder
1999 Jeep Wrangler
Home: Sumner, TX

Lake Pirate

  • ---
  • Posts: 7
Re: Onan Generator won't start ....... no spark
« Reply #12 on: June 27, 2011, 08:19:58 PM »
Problem solved..........new plugs,  points,  condensor,  and plug wires...........runs like a champ! ........Thanks everyone!
Stuck in Kansas
Older than dirt .....57
Myacht Houseboater on Milford Lake
Loves wild women ! .......... "S"

Kim (skyking4ar2) Bertram

  • Forum Staff
  • ---
  • *
  • Posts: 4075
  • I don't know what I don't know so I look here...
Re: Onan Generator won't start ....... no spark
« Reply #13 on: June 29, 2011, 11:34:29 PM »
Sounds a lot like a '57 Chevy  ;D....congratulations on your success!!
Kim & Christi Bertram
SKP 106183
FMCA 420913
----------------------------------
2012 Thor Damon Tuscany 42RQ
2014 Jeep Grand Cherokee Diesel
Trailer Ranch RV Resort, Santa Fe, NM

dennisu

  • ---
  • Posts: 25
Re: Onan Generator won't start ....... no spark
« Reply #14 on: July 08, 2011, 11:27:43 AM »
My Onan Marquis had a blown regulator assembly and it would start and run fine just no AC output so some Onan's don't need to see AC to keep running.  After a change of the regulator all fine again.

bornfree

  • Posts: 3
Re: Onan Generator won't start ....... no spark
« Reply #15 on: May 17, 2012, 03:57:53 PM »
Water Dog, you saved my life, generator, marriage, hours of work and $$$$$$  Thank You!

My Emerald 4000 (1995 model K) suddenly would not start reliably.  Every once in a while it would start and run.  Figured it was carburetion so spent about 2 weeks messing with the carb and did everything but rebuild it. Cleaned the sooty plugs twice, too. 

Then had a thought to check the spark.......only had spark when pushing START !!!!

So searched the internet, found this thread and printed out the troubleshooting link you provided.  Wonderful!

Went through the test procedure and it wouldn't start because no AC on the necessary terminals.  While I had the control panel opened....IT STARTED!

Then got looking further inside and found several wires the mice had gotten to and eaten the insulation off exposing bare wire.  One or some of them must have been shorting to ground or together.  Ran fine with it all spread out.  So taped up the wires, reassembled and it is working fine. 

I never would have found the trouble without the troubleshooting guide.  I have the Onan maintenance manual which is very little help.

BTW, the mice caused me problems several years ago.  They built a nest in the area where the timing trigger is spinning around in the center of the unit.  It had a plastic arm holding the timing magnet which broke off when mice packed the area with nest.   I had it serviced to the tune of a couple hundred bucks ($10 part plus labor).  They said it was a common problem, knew immediately what to look for.    So I wrote to Onan and complained.  They provided me with a prototype timing device which was completely round with no protruding arms to break off.  They also paid to have it installed.  Works great and no more problems in that area since. This might help someone with no start problem.     

Water Dog

  • ---
  • Posts: 2490
Re: Onan Generator won't start ....... no spark
« Reply #16 on: May 17, 2012, 06:00:04 PM »
Water Dog, you saved my life, generator, marriage, hours of work and $$$$$$  Thank You!


Probably slightly exaggerated.. ::), But I'm glad you were able to get it solved without spending the big bucks.. ;)
Dennis

"Heart is where the home is"
---------------------------------
Dennis & Vici Bernhard
2000 Bounder
1999 Jeep Wrangler
Home: Sumner, TX

tatankafenn

  • Posts: 1
Re: Onan Generator won't start ....... no spark
« Reply #17 on: September 12, 2014, 08:39:23 PM »
  :(my generator has no spark model # 4-occk.3cr/12015r ser# 67481440 . This is a unit that was given to me but is in fair shape I have signal to the coil points are working  but no fire any help would be appreciated also where can I get a wiring diagram
« Last Edit: September 12, 2014, 08:42:47 PM by tatankafenn »