Alyce doesn't like heavy rain

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

penman39

Well-known member
Joined
May 22, 2015
Posts
165
Location
Sarver, PA
During our most recent camping trip to Summersville Lake, WV, we encountered heavy rain on the interstate. My 2002 Adventurer 35U Workhorse (Alyce)seems to get a fair share of moisture in the air intake due to its location. Enough moisture will get into the air box to cause the engine to stumble. I have even had it set the CEL light. Has anyone with a similar motorhome made an adapter to the intake horn to minimize water ingress? Would you care to share your solution with a fellow Adventurer owner?
 

Arch Hoagland

Well-known member
Joined
Jul 11, 2014
Posts
4,028
Location
Clovis California
I'm assuming you have the GM 8.1 engine with the Allison 1000 transmision.

At the bottom of the air horn there should be a rubber oblong drain.

Sometimes it gets stuck and won't open to drain the water. Squeeze it a few times and it should allow draining.

What is the Check Engine Light code it sets?
 

penman39

Well-known member
Joined
May 22, 2015
Posts
165
Location
Sarver, PA
I didn't take my code reader with me when it happened and it cleared after a few starts. Assuming it was a cylinder misfire. Thanks for the tip on the airbox. I will take a looksee. I have the same chassis you do.
 

Latest posts

Members online

Forum statistics

Threads
123,912
Posts
1,257,914
Members
129,727
Latest member
JWC
Top Bottom