Any advice appreciated

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Bob T

Well-known member
Joined
May 20, 2014
Posts
340
Evening
A buddy of mine has a 2010 Holiday Rambler 42? Endeavour and has been parked now since mid October.
Last nighe, he got up for a nature call and saw lights outside. Went to front to look and found they were his lights, all dash lights on, level control lights on, just like he was going to start the coach but the ignition key in off position.

Tried to start the coach but nothing.

Turned off both chassis and house batteries for balance of night.

This AM, checked SG of house batteries and all cells good, voltage on house system 14.2v.

Chassis  batteries are maintenance free so could not check SG. Separated connections and put load tester on.  Tested poorly so replaced both this afternoon.

New chassis batteries, house batteries good but turn on house system, wait a but and everything turns on still. You can hear fuel pump (I assume).

Strange. There is a BIRD controller and a Big Boy relay.

Started the engine, ran to air up the system and he tried to turn off but would not shut down. Had to turn off the batteries (ahouse and chassis) to shut down.

Any of you experienced folks suggest where to look. 
Sounds like a backfeed to me but until he straightens this out, he has no fridge, no A/C or house lights.

Thoughts?
 

Bob T

Well-known member
Joined
May 20, 2014
Posts
340
Problem is no schematics. There was a drawing on inside of compartment door but very little of that left.

Just trying to give a buddy a bit of help.
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
76,133
Location
West Palm Beach, FL
I would not suspect the batteries with those symptoms - they are merely a stored power source and not an active control.  My first thought would be the ignition switch or the relay(s) it operates to provide power to various circuits.

Has he tried Rev Group (Monaco/HR brand owner) for help, e.g. a schematic or some ideas about what might do that?
https://www.monacocoach.com/technical-assistance
 

Bob T

Well-known member
Joined
May 20, 2014
Posts
340
Thanks for the link lynmore. Buddy does have the manual but no schematics there. No remote start.

Gary- I agree it is a problem with a relay that is getting a feed from both systems. That keeps taking me in 2 directions, first to ignition system then to emerg start system (parallel) 
He found there was a problem about 3AM Saturday morning and plans to call REV but he was told they don?t work weekends.
Start batteries replaced as they didn?t do well on load test plus they were 9+ years old.
 
Top Bottom