Battery issues

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Gnome79

New member
Joined
Jul 21, 2018
Posts
4
I think my coach battery has gone bad as it won't hold a charge, but I think I have another issue because I tried to use my emergency start to start the coach off of my house/generator start battery and that didn't work either.  I thought maybe the generator battery was low also but it started the generator no problem. Any suggestions?
 

Back2PA

Well-known member
Joined
Jul 26, 2015
Posts
5,766
I would address one issue at a time and first have your house battery tested. If it is bad, replace it and see how things work at that point
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
74,667
Location
At our Silver Springs FL home
You didn't tell us anything about the coach, year, make, model or type, so we can only guess about it. Rarely, though, does a motorhome have a separate generator battery - it starts of either the house or chassis battery. Separate genset batteries went out of style 20+ years ago.  It appears you have enough battery power to start the genset, so that is good news. Running the genset powers the house charging system too.

The emergency start function also needs 12v power (Catchh-22!) to operate the solenoid, so if both your batteries are near dead, it may not work.  More often, though, something has failed in that circuit but was undetected until it was needed.  Loose wire, bad solenoid, bad switch, etc..

Scott gave good advice - get the chassis battery working (probably just replace it) and then investigate the other problem.
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
25,274
Location
Davison Michigan
When did you last replace the battery.

I have had "Battery" issues over the years.. Originally it was a bad connection due to the factory using the WRONG type of  connector.. The last time it was the battery itself. THAT time the Emergency start/Boost button did not help (I had to use a jumper cable from one to the other)

WHen I replaced the battery I also Re-wired with the proper lug.

Been 4 years.  No problems.

Just put the 2nd battery in my car though. Those seem to only last 5 years.
 
Top Bottom