Dead Toshiba Satellite

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

thebrits

Well-known member
Joined
Mar 4, 2005
Posts
159
Woe is me.  My Toshiba is giving problems.  It all seemed to start with downloading the new version of Norton, but that could be entirely coincidental.  At first the Wi-Fi wouldn't work.  Ned suggested turning off the firewall, which I did, but that didn't help.  I was able to get online with dial up or cable, so the problem wasn't too enormous.  Yesterday it gave an error message that there was a fatal error in the Power Saving program, but things seemed to be working ok.

However, today, the dratted thing refuses to even boot up.  We're up in the Utah mountains at the moment, and there's no Circuit City (where we bought it) nearby.  Any suggestions?

TIA

Peggy & Dennis
 

Ned

Moderator Emeritus
Joined
Feb 1, 2005
Posts
25,107
Location
USA
Please don't leave the firewall off for any longer than necessary.  I'm sure I only suggested it as a quick test.  My first supspicion would be the Norton software.  Can you boot to safe mode, or won't it get past the BIOS POST?  If you can boot is safe mode, I would first remove the Norton software or even better, do a system restore, if possible, to pre-Norton conditions.

Second, you might try going in the BIOS setup and restoring everything to the defaults.  There should be an option in the setup menu to do that.
 

r2sharpe

Member
Joined
Jun 11, 2005
Posts
20
There was class action suit brought against Toshiba on the Satellite laptops.  You may want to go to their website.  Mine is real slow loading.  I rely on  my old HP  desktop.  Good luck
 

Ned

Moderator Emeritus
Joined
Feb 1, 2005
Posts
25,107
Location
USA
The deadline for filing a claim under that action was June 27, 2005.
 
Top Bottom