electrical problems

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

mrrebel77

Member
Joined
Aug 12, 2013
Posts
9
I have 2008 Fleetwood discovery with 350 hp cummings freightliner chassie. I turned on key and let it go through engine check and then cranked engine . I noticed that all electrical gauges , voltage fuel ect. were not working . turned off and back on nothing. took to mechanic and he came up with batteries were not strong enough and replaced . cleared up problem for about 6 months and now I cranked up yesterday for trip this weekend and not working again. also forgot to mention the turbo does not kick in either when this happens . anyone ever have something like this happen. would appreciate any help.
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
76,166
Location
West Palm Beach, FL
I'm told the turbo control mechanism can stick and they need external lubrication from time to time. A Cummins shop would be your best bet.

As for the electrical problem, what is the chassis battery voltage, both at the batteries and the dashboard?  Maybe something is causing battery discharge or the engine alternator isn't keeping them up.  Need more diagnostic data to get some clues.

There is a large and very helpful Discovery Owners group online - you may want to join.

https://www.discoveryowners.com/

 

mrrebel77

Member
Joined
Aug 12, 2013
Posts
9
replaced the turbo charger 6 months ago because of water leak, that's when I had electrical problems after replacement. certified Cummings mechanic did work . turbo is not working because of voltage issue. I will bring back to mechanic just thinking it might be something simple I could handle so I can use this weekend
 
Top Bottom