Heater Problem

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

camarotaran

New member
Joined
Sep 26, 2018
Posts
2
Location
Elk Grove, CA (SACRAMENTO)
Hi All,

New here just signed up. I have a toy hauler and when it is below 50Deg the heater does not heat. You turn the unit on and the fan comes on for about a minute and turns off. If it is a little warmer out or the sun is shining on that side of the trailer the heater will come on and make you sweat in no time. It has periodically done this for the last few years but turning it on and off a few times would fix the issues, not anymore!!! i pulled the cover off and nothing stood out to me. After talking to a neighbor camping one weekend he suggested that the igniter might be plugged. I would appreciate any info you can help with.

Thanks, Taran
 

darsben

Well-known member
Joined
May 30, 2018
Posts
2,595
Location
Central NY in summer beautiful Casa Grande AZ in w
I think by heater you mean furnace.
My theory is that the fan motor is not turning fast enough at cooler temps to close the sail switch which allows the gas valve to open.
As the temps outside warm up the motor will turn fast enough to close the sail.

 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
26,257
Location
Davison Michigan
Suspect list
Out of propane/Propane turned off
Ignitor gap too wide (Spark gap).
Burner orifice clogged
Solenoid valve failure
Control board failure (NOTE this comes up again)
LOW BATTERY not letting blowers spin up fast enough to close SAIL SWITCH
Bad Sail Switch.

NOTE. if you have someone go outside and monitor if these conditions exist it will not light (you will hear or feel it light if you hold your hand abou 8-12 inches from the exhaust port)

IF IT LIGHTS AND THEN GOES OUT

Orifice may be partially clogged not heating ....
FLame sensor (Thermocouple) enough or thermocouple may be bad or
Control board may not be detecting the flame (I told you it would come up again)
or bad connection.

There are a couple trouble shooting charts in the forum files.
 

camarotaran

New member
Joined
Sep 26, 2018
Posts
2
Location
Elk Grove, CA (SACRAMENTO)
Thank you guys very much. For shure not out of propane and low battery. Fresh tank and full hookup camping.

I got the trailer out of storage today to try it and of course it worked perfect everytime. I will try again soon and keep y'all posted. I was hoping to it would act up today so I can fix it, duck hunting opener is in a few weeks and will need that FURNACE.

Thanks for everything!!!
 

BoomerD

Well-known member
Joined
Jun 21, 2014
Posts
1,326
Location
Grays Harbor County, WA
Post the.make and model of.the furnace. There are some mqnuals and troubleshooting guides available on line.

http://bryantrv.com/docs.html#furnace
 

Forum statistics

Threads
123,879
Posts
1,257,549
Members
129,680
Latest member
CrosbyDave
Top Bottom