Hello, on our first venture into the untied boundries of the RV world. We bought a used A and are adjusting to our new life

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

rustywelds

Member
Joined
Feb 28, 2021
Posts
15
Location
Sprague River, OR
a question, our coach is a 06 travel suspreme.
It has a trip tek system that will flash on and off. When first turned on it takes about 20 minutes before the flash off for 10 to 20 seconds then back on for various amounts of time. It appears as if a circuit breaker or something is opening and closing. Does anyone know how this can be fixed, who I can find to fix. Thanks. Rusty
 

prnebs

Well-known member
Joined
Aug 17, 2015
Posts
304
Location
FOCO CO
Welcome to the forum! I have no idea what is going on with your TS but I'm sure someone else will be here soon. We just got our 2004 a month ago & learning about it. Welcome to the Travel Supreme family also.
 

rustywelds

Member
Joined
Feb 28, 2021
Posts
15
Location
Sprague River, OR
Hi prnebs, Thanks. we ventured back to our ranch with our new home. Since our first venture we did a lot of first and mistakes. Found out eh problem on the Trip tek or part of. When I cleared the screen so there were not 2 programs going at once. It did not flicker even once all day. But, when I got to our overnite spot I engage a screen and within 15 minute it started flashing again, also found when you put on a turn indicator that the screen didn't change. So think about send it in to have checked for sure.
But, meantime we are at our old ranch for a couple month so I sure I'll fix a few more problems and
understand things better.
We are looking forward to staying on the road for about a year at least. "Our" new home is really cool and super glad we bought it.
Take care and keep it between the bar ditches. Rusty
 

prnebs

Well-known member
Joined
Aug 17, 2015
Posts
304
Location
FOCO CO
I did a bit of google-ing because I wasn't sure if we had one or not. It looks like the company that made it stopped in 2015-17? I'm sure someone will be on board here with some info. If not you could post again in the general tech forum.

When you get a chance post a couple of pictures, its neat to see new homes!
 

rustywelds

Member
Joined
Feb 28, 2021
Posts
15
Location
Sprague River, OR
Hi, and good evening from Oregon. which was our home base and ranch. From your snapshot our looks close to your color scheme. We have a 06, It's on a Spartan chassis who I think was the company that began building them. At one time many moons ago. They built the frame rails for several chassis manufactures. I was told that Titan bought them out. They were built as custom coaches in the beginning.
So far I could ask for a better coach. We are still on the learning curve, but being in the business of dealing with every form of truck chassis built and working for a national association for 12 years as liaison between the chassis manufacturers and the equipment manufacturing, I had contact in about every form of " things " that mounted on a chassis. Plus the political side, OSHA, NHSA, and even IRS.
I tend to be able to reverse engineer things, so as a new challenge the MH is beginning a new life fo me a
at 84.
Will try to attach photo's later. Thanks for the chat.
 
Top Bottom