Help Heat Fridge and Toilet issues

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
I recently loaned my pop up to a friend for a short time and I get it back and now after fixing several things they had broken, I find that the toilet water isn't flowing out when I press the button. Also the heater isn't lighting and blowing.. and the refrigerator I have it on gas the pilot light is lit but it is not getting cold. Never loaning it out again... any advice on how to fix it would be appreciated...

Thank you
 

Ex-Calif

Well-known member
Joined
May 15, 2020
Posts
1,822
Wild guess is that the board controller or pump for all three of those is electric (DC12V). Is there a fuse panel? Batteries in good shape? All the other 12V works (lights etc)?
 

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
Wild guess is that the board controller or pump for all three of those is electric (DC12V). Is there a fuse panel? Batteries in good shape? All the other 12V works (lights etc)?
Yes it's all 12 volts the refrigerator obviously is a three-way fridge works on gas 12 volt and electric the battery has plenty of charge but has some corrosion all the lights are coming on
 

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
It's a Rockwood similar to the one above however it is fully loaded, all fuses are good lights work battery has 2 wires going to each contact battery has a little corrosion.
 

JayArr

Well-known member
Joined
Jun 13, 2020
Posts
777
Location
Mission British Columbia Canada
Lights working does not equal good battery! Measure it with a voltmeter.

The lights may still light when the battery is too low to run other things.

The pump should still run on a depleted battery but slower than normal so I'd use a multimeter to check whether 12V is reaching the pump and troubleshoot backwards if it's not there.

For the fridge, I know you said the pilot is lit but if you turn the thermostat to make the fridge colder does a full flame come on? The pilot itself isn't enough to make it cold. If you can't get a full burner flame tell us your make and model number.
 

Kirk

Well-known member
Joined
Oct 30, 2005
Posts
1,251
Location
Full-time , Escapee
Yes it's all 12 volts the refrigerator obviously is a three-way fridge works on gas 12 volt and electric the battery has plenty of charge but has some corrosion all the lights are coming on
What is the battery voltage if read with a meter between the positive and negative posts?
 

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
Ok so i got everything working other than the heater.. i have 2 full tanks and a fully charged battery i even had it connected to my vehicle while it was running and tryed it to make sure it had enough power..

It originally started by blowing clicking then nothing. BUT it only did this once.. now it does nothing when i turn it on.. no fan no click nothing, i have checked all the fuses and breakers any trouble shooting tips maybe it is something stupid i am missing
 

Attachments

  • 20211023_005916.jpg
    20211023_005916.jpg
    91.5 KB · Views: 4
  • 20211023_005906.jpg
    20211023_005906.jpg
    116.1 KB · Views: 4

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
74,979
Location
At my Silver Springs FL home
What brand & model furnace is that? Suburban like the t-stat? They all work generally the same, but the details vary. I've written a Furnace Troubleshooting article (it's in the forum Resource library) but it's geared to the DSI type furnace and yours may be pilot ignition.

Basically the furnace gets its 12v power directly and that powers the circuit board and fan. The thermostat sends its +12v to the furnace as a signal to start the fan and the ignition process. Both the furnace 12v and the thermostat 12v have to be present to get it started.
 

Ex-Calif

Well-known member
Joined
May 15, 2020
Posts
1,822
Double check that the tank is full of water. If it got winterized (drained) and is in bypass it won't stay lit.
 

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
What brand & model furnace is that? Suburban like the t-stat? They all work generally the same, but the details vary. I've written a Furnace Troubleshooting article (it's in the forum Resource library) but it's geared to the DSI type furnace and yours may be pilot ignition.

Basically the furnace gets its 12v power directly and that powers the circuit board and fan. The thermostat sends its +12v to the furnace as a signal to start the fan and the ignition process. Both the furnace 12v and the thermostat 12v have to be present to get it started.
 

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
This is it from the outside so i assume it is
 

Attachments

  • 20211024_101702.jpg
    20211024_101702.jpg
    181.6 KB · Views: 1
  • 20211024_101702.jpg
    20211024_101702.jpg
    181.6 KB · Views: 1

bar081474

Member
Joined
Oct 17, 2021
Posts
8
Location
Magnolia Tx
Here os inside the unit
 

Attachments

  • 16350888129067132611269049087242.jpg
    16350888129067132611269049087242.jpg
    80.1 KB · Views: 8
  • 1635088833182564373988315074896.jpg
    1635088833182564373988315074896.jpg
    54.8 KB · Views: 8
  • 1635088852055697854020366366319.jpg
    1635088852055697854020366366319.jpg
    67.6 KB · Views: 8

Latest posts

Members online

Forum statistics

Threads
121,176
Posts
1,220,434
Members
126,184
Latest member
Mgelmi
Top Bottom