just joined and had a question for Allison man

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

rlbachman05

New member
Joined
Oct 19, 2012
Posts
1
thanks to the site creators/maintainers for letting me join.  A quick hello to all and a question for Allison man. Before my question I wanted to say that I like the layout of the site and think it is great to have someone to talk with that also RVs with questions or just to share info with.  I have a 2002 Carriage 5th wheel 36 footer with 3 slides. I pull it with a 2002 GMC Duramax w/ an allison.  The pair have done great until today when I decided to drive the truck (after it had been sitting about a month) and it won't move in reverse and has a blinking R light and a check engine light. It will move in drive but it feels like the parking brake is still engaged, but the parking brake is released.  Any ideas of what is wrong or what I can do before taking it to a mechanic and would it be O.K. to drive it in this condition? Thanks in advance for your help!
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
73,978
Location
At our Silver Springs FL home
Allisonman hasn't been active here in over a year, so probably won't reply. Hopefully some other Duramax owner will have some experience with this problem and can give some advice. Otherwise, call a Chevy/GMC dealer and ask if you can drive it in for repairs.
 

rsalhus

Well-known member
Joined
Jul 20, 2006
Posts
1,335
I'm not a Duramax owner but I had a similar problem with a 5.9L Cummins engine and an Allison 1000 tranny in our MH.  My problem was that 4 wires running from the bottom of the Allison transmission to the NSBU switch were severed.  This caused the transmission to be derated.  When derated, this transmission will only move forward in 2nd gear, which makes it feel like the parking brake is still on.  I was able to drive it to the shop in this condition, but it accelerated very slow when starting from a dead stop. 

So I'm guessing that your transmission is derated also.  The Allison computer fault codes will tell the shop workers why it is derated.
 

Enginedr

New member
Joined
Nov 27, 2012
Posts
2
Location
Augusta , Ga
THANKS Gary, if u have an email for him, i'd appreciate if you;d mail him for me.  as for my offer, it stands
Im in east central GA, I-20 at Augusta GA, i run road service, for a select group of " friends"
 

Tom

Administrator
Joined
Jan 13, 2005
Posts
48,732
He hasn't responded to my emails, so don't hold your breath.
 
Top Bottom