lights in slide out

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Pam

Member
Joined
Sep 29, 2005
Posts
8
Location
Damariscotta, Maine
Hey folks, I apologize if this is a repeat, but my search didn't find a similar topic (actually too many returns).  So here is the problem.  The overhead lights in my slide out are not working.  Is this common?  I haven't crawled underneath yet to see if I can locate the wiring, but I suspect something has gotten caught along the way.  I didn't check all the interior lights before I bought it, so could have been this way for a while. 

Of course the manual is NOT helpful, heck it doesn't even mention the slide . . .

Thoughts?
 

Jeff

Site Team
Joined
Apr 8, 2005
Posts
8,965
Location
SD/AZ
Pam:

12V lights? My slide has a looped cable in the basement that feeds all power to the slide and is pretty easy to inspect. I would first suspect a blown fuse.
 

Tom

Administrator
Joined
Jan 13, 2005
Posts
48,526
Like Jeff, I'd suspect a fuse or, in my case, a breaker.
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
24,630
Location
Davison Michigan
In addition to the fuse and breaker and make sure the 12v systems are turned on and the cealing lights switch (if any) is on (My MH is strange in that respect)

The slide out wireing is usually easily inspected for breaks where it is under the unit, or beside it, either in or out depending on how it's hooked up.
 

Ron

Moderator Emeritus
Joined
Jan 29, 2005
Posts
18,082
Location
Home is where we park it
Could be as simple as a Ground Fault tripped.  Check the outlets in the bathroom for an outlet with ground fault reset.

 

Pam

Member
Joined
Sep 29, 2005
Posts
8
Location
Damariscotta, Maine
Well I feel very silly  :p I had plugged the cord in, but at the wrong end . . . oh well.  In the meantime my furnace ciruit board burned out, so I had to bring the trailer to the service center anyway. 
 

BruceinFL

Well-known member
Joined
Mar 12, 2005
Posts
3,205
Pam said:
Well I feel very silly? :p I had plugged the cord in, but at the wrong end . . . oh well.? In the meantime my furnace ciruit board burned out, so I had to bring the trailer to the service center anyway.?

"It's always something!"  :(
Rosanna Rosanna Dana
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
24,630
Location
Davison Michigan
Gee... My latest PITA was a burned out tail light,,, Glo-Right, easily replaced but I've never done one of those before.

That and the umbicial for my Unified Gear braking system shorted out (Thankfully I know how to fix that)

I now have one very scary halloween decoration.. Haunted leaf rake

Smile with eyes and nose, light up when button pushed and talk scary

But what is even scairer for those of us in the leaf belt... It's a leaf rake!!!!!!
 
Top Bottom