Lights with wall switch not working

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Marchos77

Active member
Joined
Dec 5, 2018
Posts
32
Location
Chuluota, FL
Hello,
I have a 2010 Tiffin Allegro Open Road 35 QBA and it seems that the interior lights with wall switches are not working.  I do know that the switches were left on all day and when I got back the lights were not working. two of the three switches were left on and those two are not working. The third works fine. I checked the fuses under the fridge and they all look good.  All the breakers under the fridge are fine as well. Not sure what else to check.
 

Marchos77

Active member
Joined
Dec 5, 2018
Posts
32
Location
Chuluota, FL
Hello,
I checked the bulbs against a known good outlet and the bulbs are good.  Going to check other fuses tomorrow to see why its not working.
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
76,141
Location
West Palm Beach, FL
I'd check the voltage at the switches to see if you have power that far. If so, the source power fuses are good and the problem is between there and the light fixtures.
 

Marchos77

Active member
Joined
Dec 5, 2018
Posts
32
Location
Chuluota, FL
Well, it appears I did not go with the simplest thing and checked to see if the switches on the lights themselves were off which they were. My kids didn't know that they could turn them off by the switch and they physically turned each light off. ARGH! Should have known better.  Thanks for the advice though.
 

IBTripping

Well-known member
Joined
Sep 19, 2018
Posts
1,703
Location
Virginia
Marchos77 said:
Well, it appears I did not go with the simplest thing and checked to see if the switches on the lights themselves were off which they were. My kids didn't know that they could turn them off by the switch and they physically turned each light off. ARGH! Should have known better.  Thanks for the advice though.

I did same thing today when I was replacing incandescent bulbs on TT with LEDs. Wall switch didn't turn on bath lights. Got out my current tester. No juice. Finally tried switch on light. Still giving myself dope slaps for not first checking the obvious.  ::)
 
Top Bottom