Network Read Only Files

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
I have set up a network using a wireless router.  The network access appears to be working as expected except for access to password protected files on my Quattro Pro spreadsheet program.

The files reside on an external hard drive attached to my desktop, and the drive is configured to be shared.  The drive appears on My Network Places on the remote laptop, but when I try to open one of these password protected files from my laptop, a message appears saying the file is "read only"  and fails to open.

What do I need to do to be able to open these files from the laptop.

The OS is WinXP Media Center Edition, which is on a XP Pro platform.

Thanks for suggestions.
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
25,255
Location
Davison Michigan
I have a different network problem... Don't yet knwo if I will fix it or just re-do the net when I got mobile

You can share files two or three ways, The check box says something about allowing others to change your files, and that can be password protected.. .So here is the list

NO SHARING
Password required to view
Password required to add/delete/edit/change
No password needed ever
 

Jeff

Moderator Emeritus
Joined
Apr 8, 2005
Posts
8,965
Location
SD/AZ
Steve:

From your desktop right click on the folders in question and see what permissions are set to make sure your laptop has full rights to those folders. You can do trhe same for the entire drive but that should hae been set when you set it up for sharing.
 

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
From your desktop right click on the folders in question and see what permissions are set to make sure your laptop has full rights to those folders.

Jeff,

That was the problem!  Thank you for your help.  The permissions I applied to the drive were not carried over to the folder in that drive.
 

Tom

Administrator
Joined
Jan 13, 2005
Posts
48,938
Steve,

I see you're learning all about permissions  ;D
 

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
Well, I spoke to quickly.  Even though I changed the permissions on that folder, I still cannot access the password protected files.

I've spent the last week making small steps in my first networking experience, encountering various obstacles.  I am sure there is a setting I need to change, so the challenge continues.

Have to admit, I've learned a lot about setting up a home network this week :D
 

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
I see the problem, but I don't know the fix.  The folders in question, on the desktop show the files to be "read only" in the attributes under "properties".  Even though I remove the "read only" checkmark and click "Apply"  the setting reverts back to "read only".

How do I permanently remove the read only attribute?
 

Pat

Well-known member
Joined
Mar 17, 2005
Posts
1,234
Location
Payson AZ
Steve:? I haven't read the other replies, but I do remember from years ago that files copied from a CD to a hard drive copy as read only, because the CD is read only.? Maybe this applies to your situation in some way.?

Select all the files at once and change the properties to deselect the read only.? You may have to select "read only", click OK, and then deselect "read only" and click OK again to get all the files changed.  In other words, change all to "read only" and then remove it.  Works on entire folders, I believe.

--pat
 

N Smock

Well-known member
Joined
Mar 9, 2005
Posts
246
Location
Long Branch, NJ
Steve said:
I see the problem, but I don't know the fix.  The folders in question, on the desktop show the files to be "read only" in the attributes under "properties".  Even though I remove the "read only" checkmark and click "Apply"  the setting reverts back to "read only".

How do I permanently remove the read only attribute?

Steve

Not sure without trying but I think that somewhere in the far reaches of the ole brain I remember that the issue of inheritance is involved. No you are not getting any money. You are trying to make a folder or file have properties that the parent does not have. You can make the child more restrctive but not less which is what you are attempting to do. Try changing the properties at the highest level to read/write and password protect it. See if that works.

Nelson.

 

Ned

Moderator Emeritus
Joined
Feb 1, 2005
Posts
25,107
Location
USA
Did you use the XP Pro encryption to password protect the files, then copy them to the external drive?  If so, it's possible that XP ME does not fully support encrypted files.  Also, is the external drive NTFS or FAT?  Encryption is only supported on NTFS volumes.

The easiest solution is to decrypt the original files on the original computer and see if you can then access them remotely.
 

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
Hi Ned,

The remote drive is NTFS and the password protection is done through Quattro Pro.. These are spreadsheets which I password protected in Quattro.

An unprotected file can be opened remotely.

I'll try some of the other suggestions as well as some other things over the weekend and report back.

Thanks to all for all the interest
 

Ned

Moderator Emeritus
Joined
Feb 1, 2005
Posts
25,107
Location
USA
Then you have to look to Quattro for the problem.  Have you tried the WordPerfect knowledge base?
 

Steve CDN

Well-known member
Joined
Jan 31, 2005
Posts
2,388
Location
Canada/U.S.A
I'll check the WP KB, Ned.  I have further discovered that only the last two files are behaving this way, and that all previous password protected files can be opened remotely.

When I was doing my previous tests, I was trying to open the latest version of my spreadsheet, and I assumed (mistake ;D) that all files responded the same way.

I can confirm that the file attributes for Read Only have been removed from all the files.

The error message on the remote computer states these files are either in use or are Read Only.  When I try to open the file as Read Only, a second message states  Access Denied.
 

Forum statistics

Threads
120,635
Posts
1,212,310
Members
125,731
Latest member
OldHilux
Top Bottom