No Shore power, Gen only powers microwave

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Tony nepa

Sep 3, 2023
When I installed the truck and coach batteries everything was working. The RV went to the local garage for the state inspection. Today I went in to find no power from the battery, which tested fine. I plugged into the house and still nothing. I ran the generator and only the microwave got power. The fuses all seem ok. When I check the control panel its as if there's no battery as it shows nothing. I'm not electrically literate so I need everything explained to me in the simplest terms. TIA~
What kind of RV you have might be useful information, but the first thing that occurs to me is that a battery switch might have been turned off. In the Beaver I had, there was not only the battery disconnect by the door (aka salesman switch), but back near the batteries there was a chassis battery shutoff switch and a coach battery shutoff switch.

Also have you taken a volt meter to the battery terminals to see what voltage you have there, both house and chassis?
I have a 2005 Jayco Granite Ridge Class C. I used the volt meter to check the coach battery and it was over 13. The plug in to the garage should be fine as I've been running outdoor things all week from that outlet. The coach battery tested fine and the RV starts right up, with power to the lights, etc.
So there's nothing coming from the coach battery and nothing from land power. The generator runs the microwave, AC, etc but no lights, water pump, fridge, etc, so the problem seems to be with the battery/land power.
Last edited:
a battery switch might have been turned off
Larry's suggestion to check your Battery Disconnect Switch is the logical next trouble shooting step. Near your coach entry door (not driver/passenger door) there is a (rocker) switch that says ON-STORE or similar. Be sure the switch is in the ON position. Check 12V lights to see if working. Hope the state inspection flipped your Battery Disconnect Switch!

The concern is you do not get 12V lights when on shore power. You have a converter/charger that should be converting 120V shore power to 12V power to run your 12V system. I do not know, but I doubt, if the battery disconnect switch interacts with the converter/charger powering your 12V system.

Since your microwave is working the question becomes do you have power at other 120V outlets to the converter/charger? The microwave likely has its' own circuit breaker.

For your 120V system uses circuit breakers and 12 V system uses fuses.
It's not from the disconnect by the passenger door. I don't see a disconnect switch by the coach battery. I turned the AC on while the genny was on and it worked, and so did the other outlets. Nothing from the battery or shore power. Normally when I flip the battery disconnect switch the control panel will immediately show the coach battery level but nothing- just blank.
Tony, when you enter via the stairs the house part of the coach and above your grab bar are some switches - steps, lights etc. Is one of those switches label ON OFF or ON STORE or not labeled? If not what are the switches labels? Not surprised no disconnect switch on the house batteries unless added by prior owner.

Thank you for running your generator and confirming your 120V system is working. The problem could be your converter/charger is not converting 120V to the 12V required to run coaches 12V systems. But question how the Air Conditioners ran without 12V power. Do you use a thermostat to turn on and control AC temperature? Normally a coaches' 12V system runs the ceiling lights and control boards for refrigerators, thermostat etc.
The control panel that shows the battery power, tanks, etc, aren't lighting up at all. The AC ran when we turned on the generator. The outlets, AC and microwave all work with the genny. THe overhead lights, fridge, etc aren't working. We tried land power and using the battery and nothing. Everything worked fine before we took it to the mechanic for the state inspection.
Re: AC. I turned it on with the knob right on the AC unit. We only use the thermostat for heat.
Tony, Thanks for the AC clarification. Your 120V power is not a problem.

Still would like to know what the switches by the stair door say? Your coach should have a Battery Disconnect Switch and generally that switch is located near house door.

Next to check is your converter/charger. Locate it and see if it has a reset switch (manual?) or is seeing power from 120V system. Do not know if your are running your coach but if are might want to check house battery(s) SOC (state of charge) since appears you likely are not charging your batteries via converter/charger.
THe overhead lights, fridge, etc aren't working. We tried land power and using the battery and nothing. Everything worked fine before we took it to the mechanic for the state inspection.
Those items are all powered by the 12V-DC side and the coach battery. You don't say what chassis your Jayco is mounted on but most likely you have 2 batteries under the hood, one for the chassis and the other for the coach side. Since you just had it inspected, I would suspect that the worker did something to cause your problem and it very likely was under the hood, if I'm right about where your coach battery is located. Be sure that you are checking the right battery as the one that starts the engine does not supply the coach does not supply the coach, except via the coach battery when the engine is running.
THanks for your input. There is only one truck battery under the hood. Doesn't seem to be an issue there. The house/coach battery is located in the rear of the Jayco, near the sewer hose, low drain point, etc.
The battery disconnect at the door isn't showing anything. I've turned it on and off and nothing- no interior lights, water pump or fridge. I thought perhaps the inspection mechanic did something but there's really no reason they would've done anything to the house battery, or the inverter. The house battery tested fine. I tested it and it was around 13. I then put it on the trickle charger and got it up to 13.48 so I don't think that's an issue, either. It's just no power from the battery or when plugged into the garage (shore power).
Do you have any power at the 12V distribution panel where the fuses are located? If not, check continuity in the cable between it and the battery. Also, monitor the battery and also the panel when to turn the converter on and off or connect and disconnect shore power. Check for an output from the converter.
Update: So plugged into land power again and the 120 Volt items turned on
without the genny running: microwave, outlets. They weren't working before on landpower but are now (we reset the inverter).
So what's not working is any of the 12Volt items, either from the battery or shore power. No fridge, water pump, overhead lights. Maybe that'll help narrow it down. The fuses seem ok.
Most house battery banks have an inline fuse to prevent a short from burning down the MH. Follow the battery cables, if you have an inline fuse it should be within 4' of the battery bank.
That's correct, I don't have any 12V power. I know which items the 12V runs and which ones it doesn't. At one point I didn't have land power, either but for some reason it's now working on the non-12V. I checked my battery with my meter and it's fine so the battery itself isn't the issue. The problem is there's no 12V power with the generator or plugged in to shore power, either. I called a tech and they suspect a faulty inverter or transfer.
Thanks everyone for your suggestions. The problem turned out to be a loose wire near the house battery.
Last edited:
Neither the generator nor shore power directly provides 12dc power. Each of those sources provides 120vac power to the onboard charger, which is part of either a converter/charger or inverter/charge (whichever you have). If that charging unit isn't working, your 12v lasts only as long as the battery has any remaining charge and the wiring to the battery is working. There are often fuses or relays in that wiring path, and in many RVs the only path to the battery is through the converter/charger wiring,
I called a tech and they suspect a faulty inverter or transfer.
I am glad to hear that you found it as any RV tech who knows his business should know that the transfer device has nothing to do with the 12V system. I suggest that you take the time to read "The 12V Side of Life." parts 1 and 2 so that you know more about how things are powered in your RV if you should ever have more difficulties.

Latest posts

Members online

Forum statistics

Latest member
Top Bottom