P30 454 temp sending unit

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

darsben

Well-known member
Joined
May 30, 2018
Posts
2,595
Location
Central NY in summer beautiful Casa Grande AZ in w
My temp gauge on my 1990 Southwind with the 454 engine is not working.
Does anyone know for sure where the sender is located for the temp gauge.
Some places I Googled say there are 2 one for fans one for temp gauge. I am in a rest area tonight and a trying to find the right one
 

darsben

Well-known member
Joined
May 30, 2018
Posts
2,595
Location
Central NY in summer beautiful Casa Grande AZ in w
So I found the wire to the temp sending unit. It is nowhere near the thermostat housing. It was just hanging in space on the drivers side of the engine. I will be darned if I can figure where it belongs.
Anyone else with a thought?

I FOUND IT!!!  It resides above the second spark plug on the drivers side of the engine. Actually all I saw was a little NUB sticking out so I pushed wire onto the nub and now it works
 

Tim.kyfl

New member
Joined
Sep 13, 2018
Posts
1
Thanks for the info! Mine is hanging on top o engine. Thought I may have to replace part in engine. I will now try and insert, if I can just get my hand in there. Might have to try from under. Can't  seem to find "fitting" from above, but, saw it from under.
 

Latest posts

Members online

Forum statistics

Threads
123,879
Posts
1,257,547
Members
129,680
Latest member
CrosbyDave
Top Bottom