squealing brakes 03 pace arrow

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

dwayne

New member
Joined
Jul 12, 2005
Posts
2
I bought my coach used and the previous owner had the brakes checked under warranty, they said that they could do nothing about the noise. I have had the coach to the brake shop and as soon as they heard the noise they said it was a vacuum leak but they could not find it and could not fix it. The squealing happens when you apply the bakes, whether you are stopped or moving, they make a very hi pitch noise.? Has anybody else had this problem, and can it be fixed?
 

jerryarlyne

Well-known member
Joined
Mar 7, 2005
Posts
628
Location
Palmdale, CA.
Hi Dwane,

You didn't say what chassis you have Ford or Workhorse but if it is a Ford the noise you are hearing is probably normal. Ford uses a power brake booster that will turn on any time you step on the brake pedal, wether the coach is moving or not. In fact, if you step on the pedal with the engine off you will hear the same noise. All normal, you can always call Ford Customer support to verify this info.

Jerry


dwayne said:
I bought my coach used and the previous owner had the brakes checked under warranty, they said that they could do nothing about the noise. I have had the coach to the brake shop and as soon as they heard the noise they said it was a vacuum leak but they could not find it and could not fix it. The squealing happens when you apply the bakes, whether you are stopped or moving, they make a very hi pitch noise.  Has anybody else had this problem, and can it be fixed?
 

dwayne

New member
Joined
Jul 12, 2005
Posts
2
Thanks for the reply, the answer to the? chassis question is workhorse w22 8.1 .
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
25,259
Location
Davison Michigan
The W22 (At least mine) also has an electric booster pump on the brake system.  I do not hear it when the engine is running, only when the engine is off, this does not mean it's not running when the engine is running.  It simply means I can not hear it.

It's not a high pitch though, very clearly what it is, Same sound my Lumina makes when I pull the breakway plug out of it

(Same kind of pump)

Vaccume leaks are hard to spot, But they fall into two areas

1: Does not matter if you put foot on brake.  (Check all hoses and connectoins)

2: Only happens when you put foot on brakes (Check vaccume booster module, nowhere else)

My lumina did the latter... OUCH
 

Forum statistics

Threads
120,651
Posts
1,212,487
Members
125,742
Latest member
Cbrown72
Top Bottom