Surburban Water Heater Not Working on LP

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

ruthandken CDN

Well-known member
Joined
Aug 7, 2007
Posts
831
Location
Ontario, Canada
It was working fine until a couple days ago.  This is a brand new rig with a brand new heater, so it can't be anything needs cleaning.  It is working on electric but not on LP.  I have tried the reset button as per troubleshooting manual.  I have tried everything they say in the troubleshooting.  What could it be?  And yes there is plenty of propane in the tank. 
Thanks for any advice.

Ruth
 
Can you describe the symptoms in more detail? Does it make any attempt to light, e.g. can you hear it sparking (a snap-snap-snap sound)? Or does it light and then go out?
 
I would check the 12V to the circuit first. If you have power, it might be the control board. Also make sure the connections to the board are secure.
 
The circuit board is outside, usually in the upper right hand corner of the heater. The high voltage lead will go from the ignitor to the board. There should be a multi-conductor connector attached to the board.

There are also a couple of high temp/cutoff units mounted close by. Might be a problem there as well. Check your owners manual for a circuit diagram. It should show those units. You might be able to temporarily bypass the cutoff to see if is the problem.
 
Back
Top Bottom