Water heater LP only works with cover door open

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Malibu39

Active member
Joined
Jun 5, 2017
Posts
41
Location
Medford Oregon
Okay water heater experts. When I run my water heater on LP, it lights up, goes for a few minutes and starts spitting and sputtering, then goes out. If I pull the cover door open to have a look it it works great, but as soon as I shut the door the flames starts sputtering.

Thanks in advance.
 

Back2PA

Well-known member
Joined
Jul 26, 2015
Posts
5,766
Malibu39 said:
Okay water heater experts. When I run my water heater on LP, it lights up, goes for a few minutes and starts spitting and sputtering, then goes out. If I pull the cover door open to have a look it it works great, but as soon as I shut the door the flames starts sputtering.

Off hand I'd say it's the air mixture adjustment. Would seem to indicate insufficient air based on opening the door making everything OK. You might try loosening the set screw and sliding the adjustment more open perhaps 1/8-1/4" and see what happens.
 

Malibu39

Active member
Joined
Jun 5, 2017
Posts
41
Location
Medford Oregon
Thank you everyone, I am camping at a fairly high elevation and didn?t realize there was an adjustment, feel kinda silly. But this forum is such a great resource I don?t mind being embarrassed now and then. Off to take a hot shower.
 

Forum statistics

Threads
120,651
Posts
1,212,493
Members
125,742
Latest member
Cbrown72
Top Bottom