Water pump will not turn on

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.
Gary posted just before me. Looking at your wiring diagram, the "controller" is switching the ground. That is why when you hook the ground to the pump it works. The "controller" is bad. The lights on the switch panel will only light when the "controller" connects the ground.
 
Gary posted just before me. Looking at your wiring diagram, the "controller" is switching the ground. That is why when you hook the ground to the pump it works. The "controller" is bad. The lights on the switch panel will only light when the "controller" connects the ground.
Perfect, thank you.

That was my interpretation as well but I wanted another opinion.
 
Gary posted just before me. Looking at your wiring diagram, the "controller" is switching the ground. That is why when you hook the ground to the pump it works. The "controller" is bad. The lights on the switch panel will only light when the "controller" connects the ground.
Me too. Looked at the wiring diagram, drafted a reply and, before I got back to it, Gary had posted one of his usually good explanations.
 
So my only remaining question is, is this the issue?
Knowing for sure will require some troubleshooting but there is a good chance that it is the problem, particularly if it has been working and suddenly stopped. If you follow the link posted by Gary to the troubleshooting guide, you will find this information.
1712108184233.png
If you have a meter to verify the 12V supply, there is nothing very difficult in this process. Good luck!
 
Thanks for all the helpful comments. The replacement relay/control board/whatever arrived in today's mail. I hooked it up and the pump works again.

The one in my photo wasn't readily available so I got an Intellitec model from Amazon which appears to work fine.

Thanks!
Thanks for the feedback. Glad you got it fixed. Which model Intellitec did you buy?
 
Some random forum post somewhere said this one was compatible. I took a chance and luckily it does seem to be interchangeable:


Intellitec 0000145100 10 Amp Monoplex Water Pump Control, Black​









  1. Intellitec 0000145100 10 Amp Monoplex Water Pump Control, Black







 
Thanks for all the helpful comments. The replacement relay/control board/whatever arrived in today's mail. I hooked it up and the pump works again.

The one in my photo wasn't readily available so I got an Intellitec model from Amazon which appears to work fine.

Thanks!
That's fine. The Intelletec controller is the most widely used model and it is wired the same.

It appears that Precision Circuits no longer markets their version.
 

Latest posts

Members online

Forum statistics

Threads
131,940
Posts
1,387,899
Members
137,695
Latest member
floofzilla22
Back
Top Bottom