2001 DAMON ESCAPER CUMMINS PROBLEM???

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Chris1374

Member
Joined
Jul 17, 2012
Posts
10
Driving home from trip last weekend and the Cummins 8.3 engine starts cutting off and on. It would just shut down and then start back up. When this occured I noticed the speedometer would jump up about 10 mph but none of the other guages reacted.  Anyone had this problem before? Sound electrical or fuel? No check engine lights or anything.
 

Mavarick

Well-known member
Joined
Jan 30, 2011
Posts
2,027
Chris, sounds like an electrical problem to me. Fuel problems usually will not repair themselves. They cut power or stop the engine from running and that?s all you get until you change the circumstances. In your case it sounds like you are losing electrical to the dash circuit. You need 12v to the fuel pump solenoid or the engine will shut off. This is what is energized when you turn the key on. Because your gauges are jumping it sounds more like a ground problem with the entire circuit rather than the fuel solenoid. See if it will do it in the driveway otherwise just check to make sure all connections are clean and tight etc. Start with batteries and battery voltage and work forward.
 

Ken & Sheila

Site Team
Joined
Mar 5, 2005
Posts
3,823
Location
S Dakota
Check your alternator connections. We had a 8.3 where the coolant filter and it's shutoff valve were located above the back of the alternator. A small coolant leak on the cooper terminals and the connection was shot. Engine cut out several time before I just wire the fuel solenoid open to keep it running (pre-electronic engine) until we could get it serviced.

Whatever it does sound like a loose connection somewhere.

ken
 
Top Bottom