Battery Drain

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

Joedetroit84

Member
Joined
Dec 3, 2016
Posts
23
I've had this 2000 Tiffin Allegro for two years now. I have a fairly new set of batteries in it (2 years or less old) . The first year there were no problems whatsoever. In the last year or so I've noticed the batteries are draining when it is not being used. One of the things I've noticed in the last year is when I turn the 12v switch to off the sound that rings is noticeably weaker. Not sure if that has anything to do with it. I've checked to see if anything is on and I have found nothing and I cannot tell what is draining this new battery. I drove it quite a ways a week ago and back home. Parked it for a week and it wouldn't start. I put  a tester on it when I started it with a jump and it says the alternator is working. So what I'm asking is this.... Is there something I'm not seeing that I should look at? Why is the battery going dead when everything works for a week and doesn't after a week being stored? What could be draining this battery?  Thanks for any starting point you might give me because I have no answer at this point.
 

SpencerPJ

Well-known member
Joined
Nov 1, 2017
Posts
4,034
Location
Midwest
I agree, sounds like the terminals are bad, maybe just need cleaned, or you could even have a bad wire. That is where I would start.  Inspect, remove, and clean first  :))
 

Henry J Fate

Well-known member
Joined
Jun 14, 2018
Posts
1,979
Too many things to list for a battery drain. First thing you need to confirm is the status of the batteries. 2 years is long enough to noticeably decrease the quality of the batteries. This is dependent on how the batteries have been managed. Best way to do that is to bring them to a service center and have them tested. Once the batteries have been confirmed good or bad, you can start chasing the battery drain using a volt meter that offers DC amps. Average meters will offer about 10 amps before the internal fuse will blow. Basically you hook up the meter in series between the batteries and the house and can monitor the amp draw. You can turn breakers off and on and de-fuse things you suspect.
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
76,166
Location
West Palm Beach, FL
You appear to be talking about both sets of batteries, the single chassis (engine start) battery plus the multiple battery "house" set.  Are both sets going dead, or just the chassis starting battery?  Do you have separate disconnects for house and chassis?  Some coaches have only a house battery disconnect.    What are the voltage readings on each set, when fully charged and after being stored a few days?
 

Joedetroit84

Member
Joined
Dec 3, 2016
Posts
23
I just serviced he batteries last month, added water and cleaned the terminals and cables which I've been doing regularly ever since this issue started. It happens to both sets of batteries. I've been keeping a maintenance charger on them normally but as soon as I take it off and let it sit for about a week they go dead. I don't have separate disconnects for both sets. It's a single switch inside the coach.
 

Henry J Fate

Well-known member
Joined
Jun 14, 2018
Posts
1,979
You should be able to put a multi-meter, set to read amps, in series and see what is leaving the batteries.

One other note...?.Right around year 2000 the wonderful RV design teams decided that charging the starting batteries from the converter (Shore power or generator) was not very important and actually abandoned the concept leaving unsuspecting rv owners with dead starting batteries. Be sure your unit is not one of those.
 

ChasA

Well-known member
Joined
Mar 21, 2009
Posts
2,325
You don't put a voltmeter in series. You put ammeters in series.
 

Old_Crow

Well-known member
Joined
Nov 20, 2016
Posts
3,257
Location
Tom's Place, California
Henry J Fate said:
One other note...?.Right around year 2000 the wonderful RV design teams decided that charging the starting batteries from the converter (Shore power or generator) was not very important and actually abandoned the concept leaving unsuspecting rv owners with dead starting batteries. Be sure your unit is not one of those.

I think you have this backwards.  My '89 coach did not charge the starting battery from the converter, my '00 coach does.
 

Henry J Fate

Well-known member
Joined
Jun 14, 2018
Posts
1,979
Maybe the lack of starting battery charging is a little broader than I have realized. My 2001 Winnebago was not designed to charge the starting battery from the converter. I believe that the lack of starting battery charging was the result of a change to the battery solenoid switch which was changed from being able to combine house and starting batteries full time to a momentary switch for emergency starting. I suspect that may be the fatal design flaw in most cases but the entire concept could have been overlooked long ago. 
 

Alfa38User

Well-known member
Joined
Oct 4, 2007
Posts
6,678
Winnibago RV's did not have the chassis battery charging feature until about 2007 when they started adding a Trik-L-Chg unit to the diesel powered RV's. On the other hand,  Fleetwood have had that feature for a long time on both gasoline and diesel powered RV's
 

Henry J Fate

Well-known member
Joined
Jun 14, 2018
Posts
1,979
There seems to have been a lot of confusion about the starting battery charging. The biggest problem caused was that there was a lack of information to inform the user of the lack of charging. I have every manual and all original documentation with my 2001 Winnebago. Not once was it mentioned anywhere in the documentation. The only way I found out was through the forum and with a volt meter. The designers apparently did not feel it was very important or maybe thought it would get swept under the rug.
 
Top Bottom