Electrical problems (only half my stuff works) -- please advise

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

plowboyjames

Member
Joined
Aug 5, 2006
Posts
7
Hi guys,

I am having electrical problems in my 1996 Kit 5th wheel. We were affected by Katrina and I am trying to avoid paying someone to fix this. I don't know a lot about campers and would very much appreciate any advice. My wife and son were staying in this when the electrical messed up.

Here is what it is doing. The A/C works and all electrical outlets work. The microwave works. The fridge won't work. The overhead lights won't work. One light does work. It must be hooked on AC (not 12 volts) since it takes regular screw-in bulbs. But none of the several small lights work (that use the little 12 volt automotive bulbs). My water heater does not work (on gas or electric). I have never been able to get it to work on electric only. I have always used gas, but now it won't even give me a spark for my gas.

Under my stove, there is an electrical panel. I see three 2-pole breakers. Each of the 6 poles is labeled (hand-written) as follows:
1) main
2) refer/conv? (maybe refrigerator / converter)
3) GFI
4) microwave
5) water heater
6) A/C

There were also 9 automotive fuses in this panel. I removed all of them and they were not blown.

On the outside of the camper, there is stuff in my front storage compartment (underneath the front overhang that houses the bed). Inside that compartment, there is a black box (the inverter maybe?), something that looks like a coil, and some kind of relay. I hear a humming noise coming from the black box. I used to hear the same noise when it was working OK. I don't have a battery in the camper.?

That's it. Should I start by replacing the inside breakers? Can half of a 2 pole breaker fail, while the other pole still works? Or should I go another route. What can I check? Is this something I can fix or should I go ahead and call a repairman? One other thing. There was a mouse in the camper at one time. I found some droppings. I don't know if it chewed any wires or not. Thanks so much in advance for any advice. God bless.

James? :D
 

Just Lou

Well-known member
Joined
Dec 25, 2005
Posts
8,105
I sounds as though your converter is not working.  Since you don't have a battery installed, can you hook a 12volt battery up to the converter output (input to your DC panel) and see what works.
 

Gary RV_Wizard

Site Team
Joined
Feb 2, 2005
Posts
73,527
Location
At our Silver Springs FL home
You don't need to do anything to the breakers - they are strictly for 120VAC power and the stuff that isn't working is all 12V power.

Since you  don't have a battery, you are relying on the 12V converter to supply continuous 12V power. It is plugged into 120VAC and produces 12VDC.  Since you hear it humming, it's probably working, so I woud guess that the power output is not getting to the rest of the RV for some reason.  Check the wires from the black box (converter) where they connect to the trailer wiring system.  There many be a box there called a battery eliminator or there may just be a terminal where the wires join. Look for a loose or corroded connection.

You may also have a battery disconnect switch somewhere, which is used to cut off 12V power when the trailer is stored for extended periods. It may have gotten switched off accidentaly or maybe it has failed. 
 

Carl L

Moderator Emeritus
Joined
Mar 14, 2005
Posts
7,239
Location
west Los Angeles
.
I don't have a battery in the camper.

Get yourself a deep cycle battery and install it in your RV.  Make sure it is charged.  Now check your outages -- they are all concerned with 12VDC which is supplied by a battery.  If that cures the problem, then hook your RV to shore power and measure the output of your battery charger/converter.  Should be about 13.8VDC for a partially discharged battery.  If not, replace the charger.
 

John From Detroit

Well-known member
Joined
Apr 12, 2005
Posts
24,798
Location
Davison Michigan
Would be easier to diagnose hands on than remotely (I'm a hands on type of person when it comes to this kind of stuff) but sure sounds like a converter problem to me too.

The breaker marked Refer/converter is, most likely the refrigerator and 12 volt battery charger/converter supply.  Since the converter is humming I'm going to assume that part is working, Now there are basically two ways to wire a converter.

Method one has it running to the light/load side of the battery dissconnect  Method 2 has it running to the battery side

Somewhere there is a disconnect) and there are advantages to both methods, I won't list them.

So, first make sure the battery leads are not shorted (Since there is no battery) you can do this by simply wraping a paper towel around them for the time being and securing with scotch tape.  If lights suddenly work consider yourself very very lucky you did not blow the converter.  Then hook up a battery as someone else suggested.

Also look for that battery disconnect switch,, Since you don't have a battery odds are you have it turned off cause why connect it w/o a battery
 

Jim Dick

Moderator Emeritus
Joined
Feb 11, 2005
Posts
7,651
Location
Titusville, FL
Hi James,

As others have mentioned it appears the output of your converter is not getting to the power panel. Some converters have 12V fuses located on the unit. See if there are any and check them. If you have a voltmeter, check the input feed to the power panel. If you don't have 12V there then the converter is probably bad. You can check the output of the converter to be sure.
 

plowboyjames

Member
Joined
Aug 5, 2006
Posts
7
Thanks for all the great advice. I am going to look at it again today. I will let you guys know how it turns out. Thanks so much. :)
 
Top Bottom