Generac 4kw fuel priming issue

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

dave61

Well-known member
Joined
Jul 12, 2011
Posts
440
Location
Tampa Bay, FL
I have owned this RV for a little over a year and only run the genny about once per month just to exercise it. The past couple months it seems that it takes longer to prime than it used to but I really don't know what might be "normal". It is located at the rear end and is not far from the fuel tank, maybe 7 or 8 feet of fuel line.

My starting procedure had been to press the manual prime button for about 30 seconds and then hit the starter button. Crank for 3 to 5 seconds and release, after releasing you can hear the automatic priming for maybe 10 seconds or so. Repeat this once or twice more and it had been starting. Lately it has been taking more priming to get it to start, at least it seems that way to me.

Once the fuel gets there it starts right away and runs well. Usually, I will run it for 20  to 30 minutes with the roof A/C on to give it a load and it runs fine. I thought it might be a function of only running it once per month so I tried it on three consecutive days, same result.

This doesn't seem like it should be normal to me. What do you all think? Is this the early sign of a pump failing? Thanks.
 
Sounds like the Auto Choke is not setting I have seen several like that both in RV's and home units. Take the air cleaner off if you can move the throttle and see if it closes. 
 
Or you have an air leak in the fuel pump's intake line that's making the fuel pump lose it's prime.  The fuel tap exits the tank through the top, so the fuel pump has to suck fuel like drinking through a straw.

A sealed line will stay full of fuel between uses, while one with even a pinhole air leak will let the fuel drain back into the tank.  The pump then has to run longer to purge the air from the fuel line before it can start pumping fuel.

There's at least one section of rubber line between the generator and the chassis fuel line that I'd suspect.
 
Thanks guys, both suggestions could be the issue. The auto choke does seem to be working although it does not close completely, I would guess it closes 80%. If I push the lever with my finger it will close all the way. I did this while cranking and it fired right away. However, I had already been priming it for a good bit so not sure if the fuel arrived or the complete choke did it. I will try it again tomorrow when it has sat a while and is cold.

The fuel line is mostly all hose so it could be there is a small leak which would allow the suction to break. This would be a PITA to replace since there is little room to get to it above the fuel tank. I will report back tomorrow after I try it again.

Also, I should have mentioned in the first post that the carburetor was replaced right after I bought it.
 
After letting it sit overnight, I started the genny this morning. I did not prime it at all but did manually push the choke linkage so it would be fully closed and it fired up after about 2 seconds of cranking. So I think we can eliminate the fuel line having a suction break which is good since replacing it would be a hassle.

There does not seem to be any adjustment on the choke linkage that I can see. There is a sort of "U" shaped metal strip that applies spring pressure to the linkage (pressure would be closing choke) that has a small wire attached to it. Guessing this might be a bi-metal temperature sensitive spring and maybe it is not applying enough pressure to fully close the choke. I do have the manual for this genny but at the moment I cannot find it. Once I do it may become more obvious...

Thanks again for the tips, this forum is great.
 

Latest posts

Forum statistics

Threads
132,447
Posts
1,395,430
Members
138,132
Latest member
OhDis
Back
Top Bottom