Onan 4000 wont start???

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

cman

Member
Joined
Sep 10, 2006
Posts
13
I have a1997 Fleetwood Flair with a Onan 4000, has worked great till trying to use it labor day weekend. just wouldn't start. gas tank on the rv is full, tried both the inside and outside start switch. checked the 5amp fuse, its ok. Pulled the air cover and filter and poured a little gas in, it would fire for a second then die.? I must admit last year and up till now we hadn't needed it, so I am thinking the gas has turned bad in the Nikki Carb. I pulled the carb but I am not sure how to get the bowl off. Does it unscrew? Or am I looking in the wrong place for the problem? I also pulled the spark plug, it was dry, also had good spark. Thanks for any and all help, I just found this forum / web sight and this is great!!! cman.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
1st place to now check in the little gas in-line fuel filter (should be easy access) right by the carb.  2nd, check the fuel line coming from thefuel tank to the genset.  They have a tendency to rot and collaspe, usually within 3ft of the fuel tank.  It's there to haul viabration in the fuel line.  I cleaned and changed the fuel filter 4 timesa before discovering the fuel line.  Even went so far as to replace the fuel pump on the genset.  Sorry for your problems and good luck
 

cman

Member
Joined
Sep 10, 2006
Posts
13
thanks shayne for your reply and I'll check those 2 items. One other thing, when pulling the carb off there was no gas in it, at least none ran out. when pulling the plunger off the bowl the gas had a old varnish smell. I'm thinking clogged jets? Need to find out how to get the bowl off----cman.
 

Ron

Moderator Emeritus
Joined
Jan 29, 2005
Posts
18,082
Location
Home is where we park it
First of all how much fuel is in your tank.  The Generator line is usually placed a bit higher in the tank to prevent one from running completely out of fuel while running the Generator.  Normally the genset will not get fuel at or below a quarter tank, although I have seen one class C that required near half tank.

If you are sure you have enough fuel in the tank them check the fuel filter and other items Shayne mentioned.  If the Genset has not been run for an extended period of time it is very possible the fuel system is plugged up due to old fuel.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
Try spraying it heavily with carb cleaner and see if that works.  If not getting fuel into the carb could be one of 4 things most likely.  Filter, gas line collapsing, fuel pump, or perhaps the accellerator pump if it has one, which I doubt on a 97  Agian  good luck and please let us know so we can delve further into the workings  Many people here know far more about them then me.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
Ron? he stated that he had a full tank.? ? Never know possibly one of the electric lines? came undone also.? ?I think he'll find it? with our advise.? If not we'll have to scratch our heads a bit more.? An old buddy of mine always said? " if it once ran, it will run again,? might take some fixun, but it will run"? ?Also one of his favorites was " start at point 1? and if there is 20 points to check, check each and everyone in order 1 thru 20, if that fails start at point 1 and repeat NEVER missing a point in sequence, to point 20,? it all fails. start at point 1 and go to 20 again.? Just cause you checked it 6 times doesn't mean thaqt's not the problem."? After many problems throughout the years, Darned if he wasn't right.? ?
 

cman

Member
Joined
Sep 10, 2006
Posts
13
well guys i still can't get it started. I pulled the carb, removed the bowl, all looked clean but I sprayed carb cleaner in anyway. I then hooked up a fuel line while on the work bench, poured a little gas in, gently blew on the line and had gas flowing thru the carb. ( with bowl off ) made sure the float worked and put the carb back on. No start. Replaced the rubber gas line coming out of the tank, it was weather cracked real bad, no start. I would think I should have gas in the line leading up to the generator. I tried sucking on the line, but got nothing nore felt like I could. Haven't found the fuel filter for the generator. Could this be the reason for not being able to suck the fuel, or is there a vacuum? I was hoping while cranking the generator with the fuel line off it would pump gas. Or does the cranking action pull the gas to the generator? Anyway I believe its a gas delivery problem, PLEASE advise, Thanks cman.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
That fuel line from the tank has a tendancy to collaspe and will not allow fuel to reach the fuel pump.  The fuel pump should be in the lower right side of the genset on the back side.  Other than that, I don't know unless the tank has to be dropped and the filter inside is blocked. 
 

KodiakRV

Well-known member
Joined
Aug 19, 2006
Posts
1,820
Location
Florida
I just bought a new MH that sat on the dealers lot for 10+ months.  In checking it out before a shakedown trip, the Onan 4kw ran for about a minute or two and then died.  Couldn't get it to restart.  All symptoms pointed to fuel starvation.

I had seen it run previously for a couple of hours on the dealer's lot.  The salesman said it had acted up once before, but they thought they had taken care of it.  (I think they may have changed the filter.)  Total time on the meter was ~27 hours.

Took it back to the dealer where the head mechanic diagnosed it as a bad fuel pump on the Onan.  They are supposed to replace it tomorrow.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
If you can't suck air, it's either a collapsed fuel line or bad fuel pump.  Those lines separate and the inside liner of the hose collapses.  That's what happened to mine.
 

Karl

Moderator Emeritus
Joined
Mar 3, 2005
Posts
5,154
Location
Elkhart Lake, WI for the summer. Work at Road Amer
Darn! Getting info out of you'se guys is really difficult sometimes ;)

Shayne, he said he replaced the rubber fuel line from the gas tank, so I think we've eliminated that possibility.

Cman, what did you suck on? The fuel line going into the carb, or somewhere else? After the fuel pump but before the carb? Heck, it could be nothing more than a bad electrical connection to the pump. 
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
Sorry? for some reason I missed that. nMaybe a wire connector came off 
 

cman

Member
Joined
Sep 10, 2006
Posts
13
the line was after the carb.( the gas line that connects to the carb ) I could not suck any air. I followed this line ( best I could } under the rv to the fuel tank. I am guessing from the carb ( the line is rubber )(( looks good, no weather cracking or visable collasping }) for about 4 to 6 feet in length then switches to a steel line that runs to the gas tank. 1 foot from the gas tank  the line then went back to rubber, this is the one I replaced because of weather cracking, thinking it was the cause of no vacuum to the carb? I jus thought by sucking on that line I shuold of been able to pull some gas, or at the very least air in the line, but nothing. Any advise is good advise. Where the rubber hose connects to the top of the gas tank, would that be the fuel pump for the gen.? Pull that and inspect / replace? thanks again, cman.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
Cman  Ifyou can't draw fuel from the tank, something must be wrong in the tank. To verify this , is it possible to get the flex line Just before it enters the tank, into a bottle of fuel and and try starting it at that time. If that doesn't work, it must be the pump.  Be careful messing with gas open.  Dangerous  Use a bottle with a cap such as a soda or pop straw would penatrate the cap so the fumes are confined, running the flex hose into the cap.  Other than that I'm stumped. cause if you can't get fuel out of the tank the fuel pump is of no matter.  Is it possible the  long flex line is collasped on the inside some where.  But then if not getting out of the tank that blows that theory.  No  Gas  from tank  Drop the tank.  I did that too, but didn't need too.  To have that done in a shop would cost about $700  You can buy, borrow, and steal lots of 5 gal gas cans for 7 big ones.  Good Luck  Maybe someone else has an IDEA.
 

Karl

Moderator Emeritus
Joined
Mar 3, 2005
Posts
5,154
Location
Elkhart Lake, WI for the summer. Work at Road Amer
Cman,
One more possibility, but rather slim - the gas cap to the main fuel tank may not be letting air into the tank, and a vacuum may be present. Try loosening the gas cap and then try starting it.

The fuel pump for the genset will be mounted on the genset itself. If you haven't done so already, replace the inline fuel filter to the genset. If you've already done that, I would disconnect the rubber line from the steel line and see if you can suck on the steel end of it going into the gas tank. No gas - blockage. To verify, stick the rubber end on the hose in a small container (beer can) full of gasoline and try starting the genset. It should start and run. If not, you may have two problems - 1) a clogged line to the fuel tank, and 2) a clogged line to the fuel pump OR non-functioning fuel pump. Disconnect the tubing going into the carb and stick it into a can to catch any gasoline. Then disconnect the hot lead going to the fuel pump, run a small wire from the battery positive terminal, and touch it to the terminal you disconneced the hot lead from. It should make the sound of a motor running and pump gas into the catch can. No sound - bad pump; sound but no gas - clogged line from pump to carb. Listen carefully as they don't make much noise when running. You'll probably have to have someone hold the tube into the catch can while you make the electrical connection. Make sure both cans are well away from the pump as you don't want a spark to ignite the gas in either one!
 

cman

Member
Joined
Sep 10, 2006
Posts
13
just got home and reading your advise. I did try the gas cap relief idea yesterday and no luck. I need to find the genset fuel filter.  I have looked and looked, I'll try again. Right now  will go out and disconnect the line leading up to the genset and also at the gas tank and check for blockage, and if that's OK I'll the stick one end in a small container of gas- reconnect the gas line to the carb and see what happens---cman
 

Tom

Administrator
Joined
Jan 13, 2005
Posts
49,042
cman said:
I did try the gas cap relief idea yesterday and no luck. I need to find the genset fuel filter.

The Onan web site shows a "service diagram" for each model. Here's the one for the 4000 MicroQuiet. You can choose other models from this page. Yours may have been superceded, but the diagrams might give you a clue where to look for the fuel filter.
 

Shayne

Well-known member
Joined
Jan 22, 2006
Posts
4,324
On mine the filter is just like one used on older Fords with carbs and screws right into the carb where the fuel line comes in? about 1 1/2 ti 2 and 1/2 inches long.? Still feel it;s a collasped line or something with the fuel pump, even if it's a wire or connection bad.,?
Fuel pump on mine was lower right hand corner of genset, hard to get to and as bad to work on.? HOudini would have had trouble if you have to lay on ground to work on it.
 
Top Bottom