Quikee Step electric door reed.

The friendliest place on the web for anyone with an RV or an interest in RVing!
If you have answers, please help by responding to the unanswered posts.

garyb1st

Well-known member
Joined
Dec 31, 2010
Posts
4,808
Location
Southern California
Trouble shooting the steps that stopped working.  By way of background, the stairs failed to close a few months ago.  The solution was to disconnect and reconnect the 4 wire plug.  This time, I've done that numerous times and nothing.  Prior to that, for the two & a half years we've owned the motorhome, from time to time, the steps failed to retract when starting out.  That was solved by turning the door switch on and off.  So possibly the door switch? 

If not the door switch, I figure it's either the motor or the door reed.  Can I bypass the reed by splicing the two wires that go to the reed?  If not, is there another way to test the reed?  I've tried a magnet but not sure it's strong enough.  If the reed is OK, I'll try to replace the motor.  Only problem I see is the steps are closed and I can't get to the clevis pin to allow them to swing freely.  If the only solution is to remove the entire step then I'll probably have to take it in. 
 
Yes, you can bypass the switch by shorting the wires. I assume (but don't know) that the switch is normally open without a magnet close and closed with the magnet close.

If you can get to the motor wires then you can try either checking to see if it's getting power or alternatively power the motor directly with 12 volts. I'd have the motor disconnected from the controller if you try the direct power method.

Also check to be sure the controller is getting power. Could be as simple as a fuse.

Good Luck
 
The door switch is a simple on/off that reports the status of the door, so yes you can jumper it to eliminate the magnet as a factor. However, it's just a status signal, not direct power to the motor. Ditto for the step on/off switch.

All Kwikee steps since 2004 use the same controller and react to the same signals (if the coach provides them). Here's a service training manual:

https://www.rvtechlibrary.com/exterior/kwikee_svc_manual.pdf
And test procedure:  https://lci-support-doc.s3.amazonaws.com/manuals/steps/ccd_0001628.pdf
 
Thanks Tom, not sure I can get to the motor.  There are two fuses under the hood.  Both are good.  I recall reading that there are three fuses.  If so, I haven't been able to find the location of the third.  Any idea where it might be?
 
My steps were/are held on with four bolts (one at each corner); fairly simple to remove and then replacing the motor is also quite simple. It is a window motor and fairly simple to match on Amazon.

Ernie
 
Ernie, a couple questions. 

How heavy are the steps? 

Is it a two person job?    If I can remove the bolts I don't want it falling on me because I can't lift it. 

Did you use a penetrating oil on the bolts to get them off?  The coach is 15 years old and I've already twisted off some small screws trying to remove them. 
 
A second person helps because of the awkward location (or place a support under them), but they are easily handled on the bench (I replaced the motor) by one person. I just supported them on blocks of wood to reinstall. I used a six point deep socket and I doubt I could have twisted the bolts off.

Ernie
 
Problem solved.  One of the pin receptacles/sleeves (sorry, don't know what they're called) of the 4-way plug was further back than the others.  I managed to push it into place and when I connected the plug, the steps worked.  Not sure why it was pushed back and probably should buy another plug just to have on hand but, at least for now, we're back in business. 

Gary thanks again for the links.  The "KWIKEE PRODUCT SERVICE TRAINING" PDF is what helped me figure out why the step didn't work.  My thought was to rule out the magnetic reed.  Rather than cut and splice the wires, I used my voltmeter to check voltage.  Sure enough 12v to the step.  So the reed was not the problem.  However when I inserted the volt meter lead into the plug I notice one of the sleeves was pushed back about a 1/4 inch.  I managed to push the wire back in and sure enough, power to the step was restored. 

Oh the joys of motorhome ownership.  And FWIW, you can teach an old dog new tricks.  ;)
 
Back
Top Bottom